[Solved] Battery not powering Feather M0

Hello, I have a 3.3v Feather M0 basic proto and the 3.3v battery will not power the device.

  • The charge light is on when both the USB and the battery are connected.
  • When I disconnect the USB the battery does not auto-switch and take over powering the Feather.
  • Testing the battery yields a 3.92v charge exists.

Does anyone know what to check next?

Show a drawing (NOT a Fritzing picture) of how you hooked it up.

The battery is connected via the JST connector. Thank you for the reply.



Please check the red and black wires. I just saw another picture of this board (or a clone) that had them wired the other way around!

Adafruit Feather M0 Basic Proto - ATSAMD21 Cortex M0 : ID 2772 : $19.95 : Adafruit Industries, Unique & fun DIY electronics and kits , 4th image.


Adafruit (no clones there!):

This photo confirms that the orientation spline does face up.

Some rechargeable LiPo batteries from eBay have opposite wiring!

Had to swap mine to get it to work on my Feather compatible board

Thanks reversing the wires did indeed work!

Suggest you edit the title of your first posting to "[Solved:]Battery was not powering Feather M0 when reversed!"

Done, thanks again to everyone who helped!