[solved] Burn bootloader to UNO using NANO as programmer

Hello.
I've bought several Atmgea 328p (2x14 pins) that doesnt have the bootloader loaded. I'm going to use them on a standalone application without arduino board.

I'm trying to use an Arduino Nano as programmer, and placing the atmega chip on the UNO board.

I've followed the tutorial, but after finnishing, I can't upload nothing to the UNO board.

I've uploaded the ISP skecth to the Nano, connected pins 11,12,13 between boards, Reset on UNO from Nano pin 10, and of course vcc and GND.

The ide says bootloader burning completed, but when I try to upload to the UNO I cant... I'm selecting the UNO board and the correct COM port also.

On the sketch i've tried Uncommenting the line "to use the old Uno style wiring"

When I click Burn bootloader, which board should be selected? The target board or the programmer board?
I've tried both with no succes.

What I'm doing wrong?

thank you very much!

You should select the target board (the Uno). In this case it might not matter too much as both have the same processor, it only determines which bootloader is loaded into the target and the Uno and Nano bootloader are similar enough.

You are aware that you don't have to burn the bootloader? That's only needed if you want to be able to upload via USB; if you don't have that need, you can also upload your sketch directly via the Nano.

I don't think that I can really help you further, I've never used the Arduino as an ISP.

1 Like

What happens if you upload a sketch, instead of the bootloader?
F.e. the blink example, to see if the UNO is still working properly.

Don´t forget about using the "Sketch"->"Upload with Programmer"-menu instead of "Upload" :wink:

1 Like

I didnt know that, now I do :grin:
Anyway, I want to burn the bootloader for future use.

I finnaly got it working. I found an atmgea328 with the bootloader already burned, and used the UNO as programer for a standalone atmega on a bredboard as target.

I dont know why it doesnt work using NANO as programmer and UNO as target, but is working now.

Thank you.

Good to hear, that it is working now!

Maybe a problem with its bootloader? There is an "old" and "new" Bootoader available. Chinese-Clone-Nanos often use the old one. Bus for some time, you see more and more with Optiboot, which is the current one.

Or, when you just hit upload, you overwrote the "Arduino as ISP"-Sketch.