(Solved) Upload Error: "avrdude: stk500_getsync(): not in sync: resp=0x30"

I received an UNO R3 that I have fruitlessly tried to get working but have had no luck. I corrected the serial ports. Updated my drivers. Verified my board type. Verified the built in led works upon pressing the reset to confirm a bootloader exists. Downgraded to an older version and then tried uploading to the latest version and neither helped. Made sure nothing was connected in Pin 0 and 1. This is a stock, new out of the box board that I get the following error when uploading. “avrdude: stk500_getsync(): not in sync: resp=0x30”.

The PC is an HP mobile workstation 8510w with windows 7 on 64bit.

Suggestions or help. Growing disappointed in arduino’s compatibility issues.

Uno R3

front.jpg

front.jpg

OK... So do you get anything in device manager when you plug it in? If so what?

Port is identified ‘Arduino Uno (COM3)’

drivers.PNG

port.png

prog.png

Hm... Has this had any sketch loaded on to it since new?

Have you tried a new cable?

Is there anything else plugged into it?

On original UNO R3 LED L should blink fast 3 times after power ON (or connected to USB) or reset button press. It means that the bootloader was activated. Then normal sketch should run after short period if no upload start. On this board is blink sketch pre-uploaded by default - LED should blink in 1s period. Is it as described?
Another thing you could try is to switch on verbose mode during upload (in Preferences) to obtain more detailed log.
Hmm, response 0x30, 0x20, 0x30, 0x20…: Wrong cable?

Chilli,

I have tried loading multiple sketches with no luck.
I have not tried a new cable but have read about this as an issue. My cable the one that came with the board unless I mixed it up with another cable… (any suggestions on what would cause issues related to the cable)?
Nothing else is plugged in.

Budvar,

The Uno LED closest to pin 13 does blink three times fast upon uploading initially then throws an error and stays on. The board does this same blink sequence and stays on when I start the computer, initially plug in the board or press the reset button on the board.
The LED does not seem to follow the intended blink function as it stops blinking and stays on which would suggest there was an error in the loop ( I assume ).
Not sure what I am doing in the verbose mode but i’ll try both compile and upload to see what outputs.
Wrong cable, not sure. as I said its the same cable that came with the board but Ill cycle through all the cables I have with a similar connection.

Thanks for the feedback guys.

verbose.PNG

You have to check the box "Show verbose output during: [ x ] upload" to obtain more detailed log and provide an output.

3 fast blinks are in the beginning of the bootloader after reset prior to start uploading or start of an application (sketch). It means that the bootloader is still present in flash memory and UNO should be able to upload sketch.

Most of these boards should have the blink sketch loaded by default so should at least do that once powered up.

Are you able to try it on a different port or machine of only to see if the blink sketch then runs?

I tried it on a different machine and it had a similar error.
Its a very fast three blinks. then nothing for a second, then solid led on. the IDE stays uploading as seen in the attached.
I also tried three different cables and a no go.
attached is the verbose.

Blink video test

https://www.youtube.com/watch?v=sEmuEsKDWV8&feature=youtu.be

Blink is okay, it should looks like this if the bootloader is present and ready for download. L stay on after because of there is probably no sketch loaded. Verbose output is not enough. It was changed in 1.6.0 just only one -v switch is in command unfortunately. In previous version 1.0.6 there were -v -v -v -v which provided detailed output of each byte. So could you try to run it from command line? Just add 3 times -v switch or try older version of the Arduino IDE 1.0.6 http://arduino.cc/download.php?f=/arduino-1.0.6-windows.zip. I am curious what’s up early at the beginning of communication. I’ve attached an example output from v1.0.6 for your imagine.
Did you try different OS? Could you provide video from the download try (rx,tx leds)?

upload.txt (24.8 KB)

I note that you are uploading to COM 3. Can you check which com ports are available with and without the board plugged in. (In the IDE).

Good news every one, my arduino uno is now completing the upload of sketches.I will verify further with more probing but here is my solution thanks to Chili and Budvar above!

Unplugging all usb connections I restarted my computer. I then plugged in the arduino and manually set 'COM1' in the advanced menu under ports. I restarted the computer with the arduino plugged in. I opened the device manager to verify the arduino is recognized still then matched the Com# port in the tools menu in the Arduino IDE program. I then attempted to upload a sketch. I repeated manually changing the 'Com#' then restarting and matching the Arduino port till I found a match.

Wooh!

Nice to hear good news! :) So what is the difference in port setting from previous? Could you provide e.g. screenshots for other people with the same problem?

Well apparently it’s a common problem that at first I thought I already addressed. Initially I was under the assumption my PC would automatically select the correct com#. I’m not sure if among various other issues I resolved were the catalyst to me creating this port issue from myself. But one things I stumbled over was restarting the computer to set the com port. Each time I manually changed the port I needed to reset the computer. Since my pic has multiple usb ports not including docking station ports it also didn’t hurt to unplug all other use ports when I systematically went through selecting the ports.
I’ll provide some print screens shortly. But another difference I noticed were the words"Arduino UNO" showing up next to the com# when viewing ports in the Arduino IDE software when I reset the computer to the correct com#.

Update coming

We are still curious... :)

Hello, sorry for the delay.

Intro Rant Gist:
I recently purchase an aftermarket UNO to see if i had similar issues just for fun. Based of what I had read I was concerned when I plugged in the board and had the same sync error originally encountered. In short, the same sync error will occur in one week old, 2 year old and aftermarket UNO from some suppliers( No guarantee, missing bootlog would void such a statement) .
The error code titled in this intro is something i can frequently run into and follow a simple step process.

Original Problem:
The error code “not in sync” arises for me detailed earlier.

Solution:
Going into the path to adjust the com# described earlier and adjusting the number, resetting the computer each time till the board uploads.

Steps:
As described the vague path is:

Systems–>Device Manager–> Port selected after updating driver–>properties–>port settings–>advanced settings–> Com #

The com# as shown in the attached print screen shows what com#'s are in use.

First update the software/ driver for the board i you haven’t already described earlier.
With the board plugged in restart the computer.
Open the Arduino software (IDE) Select the appropriate board type and Visible com port.
Attempt to upload the sketch (if the sync error remains continue)
Select a different com# not in use in the advanced settings.
with the board plugged in restart the computer.
Repeat opening the IDE and selecting the board and com then upload the sketch.
If you have multiple devices visible on your IDE and Windows port its important to unplug and replug in the board to identify what ports are constantly in use to not get confused.
Restarting between changes is also important.
Additionally, when viewing the board and port # be sure to look for a updated name next to the selected port#.
If your board like mine is a Uno windows may select the name (Arduino Uno) or the name can be changed in the device manager advanced settings of windows if you like. I showed this earlier in an image.
If this is not next to the port you selected, you may have to restart the computer, and if it still dosent work cycle through to a different port #.
In my case I have three boards so the com # for one is different for another so although it shows up in the IDE it wont update the board until i cycle through to the correct com #.
Confusing I know.

But this gist as i sip down some Glenlivet is to restart the computer after connecting a board. the restart each time you need to change the com#. and try to select the lowest com#'s first.

This is advice from a very green novice so please take these words as theoretical and not fact. (large grains of salt)

Ask questions if you have then and ill check in every so often as i encounter new issues I attempt to resolve myself.

Make sure nothing is connected to Tx / Rx, (at least on the Uno). They are used for uploading.