Spaceship Interface -problem uploading to board

I finished typing the code and then connected the board, verified and uploaded the code but this came up. Any help is greatly appreciated. Thanks!

Arduino: 1.6.8 (Mac OS X), Board: "Arduino/Genuino Uno"

Sketch uses 1,248 bytes (3%) of program storage space. Maximum is 32,256 bytes. Global variables use 11 bytes (0%) of dynamic memory, leaving 2,037 bytes for local variables. Maximum is 2,048 bytes. avrdude: ser_open(): can't open device "COM1": No such file or directory ioctl("TIOCMGET"): Inappropriate ioctl for device Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

int switchState = 0;

void setup(){
    pinMode(3,OUTPUT);
    pinMode(4,OUTPUT);
    pinMode(5,OUTPUT);
    pinMode(2,INPUT);
}
void loop(){
    switchState = digitalRead(2);
    // this is a comment
    if (switchState == LOW) {
  // the button is not pressed
  
  digitalWrite(3, HIGH); // green LED
  digitalWrite(4, LOW); // red LED
  digitalWrite(5, LOW); // red LED
}
  else { // the button is pressed
    digitalWrite(3, LOW);
    digitalWrite(4, LOW);
    digitalWrite(5, HIGH);

    delay(250); // wait for a quater second
    // toggle the LEDs
    digitalWrite(4, HIGH);
    digitalWrite(5, LOW);
    delay(250); // wait for a quater second
    
    }
  } // go back to the begining of the loop

Select the COM port corresponding to your arduino from the tools - > port menu.

Thanks!