Sudden error: "Error loading Python DLL"

Last time I played with IDE 2 weeks ago it was all fine.
All of a sudden I started getting this error,
The only thing that was changed on this PC over the last few month was installation of CURA 4.10.0

Here is the error:

Error loading Python DLL 'C:\Users\ectar\AppData\Local\Temp_MEI79962\python39.dll'.
LoadLibrary: The specified module could not be found.
exit status -1
Error compiling for board Adafruit ItsyBitsy nRF52840 Express.

This is Windows 7, python-3.8.10-amd64 installed
Python 3.9 will not run on Windows 7

Please help !

I don't see that the "Adafruit nRF52 boards" platform of the "Adafruit ItsyBitsy nRF52840 Express" board specifies any particular Python version dependency.

Do you get the same error if you run the command python --version from the Windows cmd or PowerShell?

Were you able to resolve this? I've tried the Adafruit Feather nRF52840 Express and the Adafruit CLUE both have the same error on Windows 7 with python 3.8.10.

I've had no problems using a Windows 10 laptop and python 3.9.6.