Suddenly can't start arduino ide on linux

Since today i am not able to start the arduino IDE on my Linux Manjaro.
The only thing i remember is that my system hard drive was totally full (0 MB).
But i cleaned the harddrive in the meanwhile but Arduino does not start anyway.

if i start it via terminal i get the following message:


Picked up JAVA_TOOL_OPTIONS: 
Set log4j store directory /home/basementmedia/.arduino15
java.lang.NullPointerException: Cannot invoke "processing.app.debug.TargetBoard.getContainerPlatform()" because "board" is null
	at processing.app.Base.rebuildProgrammerMenu(Base.java:1705)
	at processing.app.Base.<init>(Base.java:286)
	at processing.app.Base.main(Base.java:150)

Can anyone help? I can’t figure out whats the problem here.

Best wishes
Daniel

I will take a SWAG, I use linux for all my arduino stuff. Have you tried to restore from your backup. If that does not work copy all of your files, libraries etc to another drive. Try to update:

  1. sudo apt-get update # Fetches the list of available updates.
  2. sudo apt-get upgrade # Strictly upgrades the current packages.
  3. sudo apt-get dist- upgrade # Installs updates (new ones).
    If this does not work then, them delete the IDE and reinstall it (you did save your files). Do not install as superuser or you will have to operate it that way, I learned that one the hard way. Hopefully you will get some better answers from other users.

Now it works.
I had to delete the arduino15 folder in the User directory.

1 Like

Great job, thanks for letting us know.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.