tip120 reduces power?

i used this as a base for a project that i am doing, i have now copied this exactly, without the pot.
http://itp.nyu.edu/physcomp/uploads/arduino_bb_pot_transistor_motor_diode.png

Instead of getting lots of extra power, im only getting about .2 volts to the motor.

I tested the voltage at at the collector, its 6v*, when no power is sent to the base, 0.9v when power is applied to the base.
I tested the voltage at at the Emitter, its 0v when no power is sent to the base, 0.1v-0.2v when power is applied to the base.

I am using exactly what they say here, the tip120, (i have tried about 5 tip120s, so i doubt its a fault with it)
http://itp.nyu.edu/physcomp/Tutorials/HighCurrentLoads

I also noticed that when i share the grounds, i can no long upload to my arduino (uno)

*or 7.4v if i turn up the wall wart, just confirming power is comming from the wart.

Anyone got any ideas, cause i am stumpped.

Added l8r
Well, it seems that although the readings are wrong, i do seem to actually be getting higher voltages, anyone know why its not reading correct. or why you cant upload with shared grounds.

The tutorial shows two methods of controlling the transistor: PWM with analogWrite() and another with digitalWrite(). Which method are you using? The former method might confuse your meter.

You should include a 2200 resistor between pin 9 and the base of the transistor. Treat your output pins as sources of infinite amperage and if you don't choke them down you're at risk of burning them out. The pin is limited to 40ma and you only need 10ma to turn on the transistor; 5V / 2200 ohms = 23ma. Recheck that you're getting 5V from that pin... or move on to the next one, I guess ;)

The red jumper on the far right of the breadboard is unneeded and might trick you into hooking something up wrong. In general, just recheck your wiring for any mistakes.

The circuit you cite is for a logic level MOSFET, not a TIP120 darlington. You may have overloaded the digital pin as you've connected it directly to the base of the TIP120 without a current-limiting resistor.

The voltage readings you are getting suggest that the TIP120 is switching exactly as you want so I suspect there is a poor connection somewhere, or the power supply can't provide enough current for the motor.

Firstly put a resistor between pin 9 and the TIP's base (1k to 4k7 is about right).

Then measure the supply voltage with the pin 9 driven LOW, and then with it driven HIGH.

I know the pic shows a mosfet, but it should be a tip120, (the program that generated that, fritzing, only has a mosfet model), I put a 10k resistor in, and turned the volts up, its actually a bell i am running, so it needs atleast 4 volts. I still get low voltage readings, but it does seem to be putting out the right power as the bell would not work on such low power.

I have an 8v/2a transformer that i want to use, i think it might be ac, but i can just put a rectifier in if it is (i think), how can i convert that to 16v/1a easily. The reason being, the bell wire is about 25m*2 long, and the voltage drops to much for it to work, so i figured that if i doubled the voltage, it might work.

I actually intend to run 4 8 volt bells, cycling through them dinging them for a second or so each, thus distributing the smaller transformer across them all.

Anyone know why the board wont upload when the grounds r joined ?