Treiber für Mega2560 und Due unter Win10

Hallo an alle! Vl kann man mir ja hier helfen? Ich habe ein Mega2560 und ein Due-Board(beide von SainSmart). Für beide Boards lassen sich die Treiber unter Win 10 nicht einbinden. Einmal kommt die Meldung, daß er die datei nicht finden konnte oder es kommt die Meldung, daß die digitale Signatur fehlt. Die Fehlermeldungen kann man auch leider nicht umgehen und die Installation weiterführen, wie noch unter win8. Hat irgendjemand eine Idee oder gar eine lösung parat? Vielen dank im Vorraus Steffen

Schlechte Idee Win10 zu installieren.

Wende Dich an ein Win10 Forum um zu erfahren wie man Treiber für WIN8 bzw nicht signierte Treiber auf WIN10 installieren kann. Frage auch SainSmart als Hersteller.

Grüße Uwe

Danke für deine Antwort Uwe. So schlimm finde ich win 10 nicht aber sicher ist das Ansichtssache. Auf dem Laptop jedenfalls funktioniert es und der hat auch Win10, da werden beide Boards erkannt. Allerdings mußte ich in der IDE noch den DUE über den Boardmanager nachinstallieren. Ich vermute, daß mein System auf dem Hauptrechner zuviel Treibermüll enthält. Im Mom weiß ich noch nicht, wie ich das bereinige, weil eine Win10 Installations-CD habe ich logischerweise ja nicht und mein System kann ich im Mom nicht neu aufsetzen, es würde mir zuviel verloren gehen. Da werde ich wohl erstmal auf dem Lappi programmieren müssen. Es scheint jedenfalls nicht am Win10 zu liegen und auch nicht an der IDE 1.6.5 Die Boards werden im Gerätemanager ja erkannt und auch beschrieben aber jeweils mit einem gelben Dreieck mit Ausrufezeichen und wenn man den Treiber aktualisieren will, kommen genannte Fehlermeldungen. Dies ist auf dem Laptop nicht der Fall gewesen. Ich vermute daher Treiberkonflikte. Grüße Steffen

Software/Betriebssysteme die erst seit kurzem auf dem Markt ist finde ich einfach gefährlich. Die Kombination mit anderen Programmen ist wenig "erforscht" und die Erfahrung der Helfer im Internet ist begrenzt. Ich mag nicht als Tester fungieren. Deswegen sehe ich WIN10 noch als nicht sinnvoll an.

Auch existieren noch keine signierte Arduino Win10 Treiber. Auch nicht bei arduino.org

Grüße Uwe

Prinzipiell magst Du da Recht haben. Win10 ist aber schon, zumindest als technical preview, seit einem Jahr zum kostenlosen test draußen, da wirds genug Tester gegeben haben. Wie gesagt, auf meinem Laptop mit Win10 gab es keine Probleme, Boards wurden erkannt und ich kann sie mit der IDE 1.6.5 programmieren und es funktioniert alles, da waren aber vorher eben noch nie Treiber für Arduinos geladen.
Ich muß jetzt nur versuchen meinen Treibermüll zu entsorgen und das neu zu machen, das wird warscheinlich nur über ein Neuaufsetzen oder einem “Registry durchforsten” möglich sein.
Trotzdem Dank für Deine Antworten :slight_smile:
Gruß, Steffen

Du hast recht mit den Vorversionen aber warum kommt dann die Korrektur für das Problem erst jetzt und für bestimmte Modelle erst später. Welche sind die ominösen anderen Kammarahersteller/Modelle?

Mit dem Treiber entmüllen kann ich Dir leider nicht helfen.
Grüße Uwe

Man kann ja nicht alles nur Microsoft anlasten...wie viele Hersteller geben keine oder ungenaue Angaben zu implementierter Hard- und Software, da wird natürlich eine Treiberprogrammierung nicht einfach. Nichtsdestotrotz ist es schon wahr, daß neue programme genügend Bugs enthalten, die einem das Leben schwer machen können.

Grüße, Steffen

Input_de: Man kann ja nicht alles nur Microsoft anlasten...

Doch. Wer zur Hölle behauptet denn mit jedem neuen Dreckssystem, dass es das beste Windows aller Zeiten sei?!

[x] Microsoft [ ] jemand anderes

SCNR

Gregor

Wenn sie sagen würden, daß das vorletzte das beste Betriebsystem aller Zeiten sei, dann kauf ja niemand das neue. :o :o

uwefed: Wenn sie sagen würden, daß das vorletzte das beste Betriebsystem aller Zeiten sei, dann kauf ja niemand das neue. :o :o

Stimmt. Das dürfte der Grund sein, warum sich nach XP immer noch Leute für ein „Update“ entschieden haben. Ein Freund hat mir neulich erzählt, dass viele kleine Andwendungen, die früher noch dabei waren, jetzt fehlen (z. B. dieser kleine Audiorekorder).

Am Ende wird alles gut. Und wenn noch nicht alles gut ist, sind wir immerhin auch noch nicht am Ende :-)

Gruß

Gregor

Hallo,

wegen den fehlenden Installationmedium nach Upgrade und Neuinstallation oder was weis der Geier. Dafür gibts ein Media Creation Tool. https://www.microsoft.com/en-us/software-download/windows10

starten, "Installationmedien" auswählen, dann Sprache, Version, 32 oder 64 Bit auswählen. Dann entweder gleich auf Stick erstellen lassen oder ein .iso runterladen.

Am Ende vielleicht noch dieses Tool verwenden. Man sollte aber wissen was man damit macht. http://www.oo-software.com/de/shutup10

Hallo,

ich habe seit kurzem eine Testinstallation von Windows 10, habe die portable IDE geladen, den Treiber aus dem Verzeichnis installiert und der Arduino wurde nach anstecken sofort erkannt und konnte geflasht werden. Hast Du die Anleitung dazu gelesen und befolgt?