Upload error: avrdude: ser_open(): can't set com-state for "\\.\COM17"

Ok. Then I must apologise, I cannot help more.

Does it work with another computer? If the same problem exists, then your Arduino is probably broken. Oh, I read the first post again, problem lies in your Windows. Drivers are ok?

Kari

yes it works an my asus netbook as i said before yes, the seems to be ok

(deleted)

Without knowing what sofware and virtual com-port drivers are installed in your Windows, it's hard to guess, what is going on. Bluetooth drivers can be one, but it doesn't explain, why COM10 don't work when connected.

Kari

Hi,

I faced exactly the same troubles on my Arduino UNO, and went through - reboot (multiple times...) - driver re-installation - Arduino application re-installation.... - change the micro-controller

And finally bought a new Arduino UNO and it worked again immediately.

I don't know if we'll find how to solve the problem, I think something failed on the board while connecting a number of steppers directly, but I did not manage to find out the root cause. At least, a workaround with a new board immediately works fine !!!

i am able to fix this problem very easily... just press reset button on arduino and unplug from usb and go to the arduino software installation directory (c:/program files/ arduino) and open drivers folder and open dpinst-amd64 by double clicking on it and just install that if it not runs may be your system runs with 32bit and open the file below the previously opened file and install it again.. close arduino programming software and open it again and choose your board and com ports and now it should upload to your board...enjoy...

1 Like

got it its working thank u aditya999
first let me tell u the cause of my problem i tried connecting a potentiometer to analog pin 0 and connected to processing( via serially) in this process something went wrong and my device started to connect and disconnect from computer . i ignored and tried again now time my rx led started to glow continuously instead of tx pin in few seconds it kept quite so i disconnected and reconnected it. now i tried to write some codes to it and got

avrdude: ser_open(): can’t set com-state for “\.\COM6”

message so i tried a lot of things later i came across aditya999 post and tried it it worked but only once so i tried to analyse the problem what is the msg that is displaying then i got some overview of it it goes something like this (explaining in layman lang )
the device cant open the files related to arduino(avrxxx) which is located in the com 6 port and the port status cant be updated with new values so resolve it manually.

aditya999 method is really working (with that my arduino responded once and again it kept quite) so i had made few adjustments

  1. reset the arduino by pressing reset button
  2. uninstall all the arduino compiler files including drivers from the device managers
  3. connect and check whether the arduino is shown in device manager if shown then uninstall it
  4. reinstall the arduino compiler and hook up arduino to it
  5. reinstall all the drivers
  6. at this time you will see that the com port had changed if it didnt then change it manually from device manager
  7. cross ur fingers and write the blink code to it by now this should work .

msg me if u have any queries to tejaswi.pandava@gmail.com

dude unplug you're device or try to upload an old program that u have uploaded.

dude unplug you're device or try to upload an old program that u have uploaded.

I kept getting this error too.

To fix it I had to close the Arduino programs, hit the reset button on the arduino and then unplug and plug the arduino back in.

I was doing lesson 10 in the Ultimate Starter Kit Guide.

I could enter a few numbers to make the motor spin faster, but then the program would just freeze.

I'm on win7 32bit.

ADITYA999: i am able to fix this problem very easily... just press reset button on arduino and unplug from usb and go to the arduino software installation directory (c:/program files/ arduino) and open drivers folder and open dpinst-amd64 by double clicking on it and just install that if it not runs may be your system runs with 32bit and open the file below the previously opened file and install it again.. close arduino programming software and open it again and choose your board and com ports and now it should upload to your board...enjoy...

Thanks ADITYA999 ! your solution worked for me! And thanks GaryP for posting!

ADITYA999: i am able to fix this problem very easily... just press reset button on arduino and unplug from usb and go to the arduino software installation directory (c:/program files/ arduino) and open drivers folder and open dpinst-amd64 by double clicking on it and just install that if it not runs may be your system runs with 32bit and open the file below the previously opened file and install it again.. close arduino programming software and open it again and choose your board and com ports and now it should upload to your board...enjoy...

Thanks ADITYA999 ! your solution worked for me! And thanks GaryP for posting!

try to recover previous driver by devicemanager or something like that (i don't know how it's written on a English pc because my pc is in Dutch)

Hi

Do you use serial output in your program (Serial.print(...), etc.)? It can obviously interfer sketch uploading. Try to plug out and then plug in your device and immediately press "Upload" in your IDE - Arduino loader waits a few seconds for a new program to be uploaded before start executing and thus lock the port.

Cheers.

Thought I would pop in to offer an alternative solution. Having spent days working on this same fault with my new R3 clone, trying all the fixes available and pulling out what little hair was left. I finally traced my fault to a broken core in my USB extension cable which I'd spliced through a wall. While not everyone will have cables running through walls, my advice is still this... try a new cable first :( :(

I could fix this problem! Maybe this solution will works for you:

  1. in device manager I had unnistalled the drivers that I had. After reconnect it then it appears in "Other dispositives" with the name "USB 2.0Serial". There are cases that it appears like "FT232RUSB UART".

  2. my serial conversor chip on arduino uno board is "CH340G". Check this on your controller boards because others like "CN480661" has another fix method. If you can't find this chip maybe this video could help you (in spanish, sorry, is where i found the solution): https://www.youtube.com/watch?v=F4ar5sjbZFg

  3. download the drivers "CH341SE" from this url: https://www.dropbox.com/s/3csnhlsbdrznbp3/CH341SER.zip?dl=0 and then decompress it in a folder

  4. in device manager check whether the arduino is shown (reconnect it for that if you didn't do it in `step 1) then do right click -> update software -> browse software in the computer -> examine or browse

  5. Now you have to search the folder in which you decompress the drivers (step 3). After then pulse accept, ignore any advertice and continue. Then it will install the drivers and you will be able to use your arduino.

NOTE: If in this last step windows has an error you need to enable the unknown digital signature installation. check other tutorials for this

NOTE2: sorry if my english is not good, my computer is in spanish, I hope this will help you

Re-installing Arduino Application Solved the issue for me.

its sometimes caused by driver issues on a Windows based PC, I do have lot of Android drivers due to testing and also couple of Arduinos to play with.

This communication error recently started and I was able to solve by unistalling the Arduino Application and re-installing the same.

Those who have projects in ~documents/Arduino should consider backing it up before un-installing else sketches would be LOST.

Avalonikal: I could fix this problem! Maybe this solution will works for you:

  1. in device manager I had unnistalled the drivers that I had. After reconnect it then it appears in "Other dispositives" with the name "USB 2.0Serial". There are cases that it appears like "FT232RUSB UART".

  2. my serial conversor chip on arduino uno board is "CH340G". Check this on your controller boards because others like "CN480661" has another fix method. If you can't find this chip maybe this video could help you (in spanish, sorry, is where i found the solution): https://www.youtube.com/watch?v=F4ar5sjbZFg

  3. download the drivers "CH341SE" from this url: https://www.dropbox.com/s/3csnhlsbdrznbp3/CH341SER.zip?dl=0 and then decompress it in a folder

  4. in device manager check whether the arduino is shown (reconnect it for that if you didn't do it in `step 1) then do right click -> update software -> browse software in the computer -> examine or browse

  5. Now you have to search the folder in which you decompress the drivers (step 3). After then pulse accept, ignore any advertice and continue. Then it will install the drivers and you will be able to use your arduino.

NOTE: If in this last step windows has an error you need to enable the unknown digital signature installation. check other tutorials for this

NOTE2: sorry if my english is not good, my computer is in spanish, I hope this will help you

This solution worked for me when none of the others did.

THANKS :-)

see the device manager of your computer to see. what port the pc is showing

I tried all the fixes such as pressing the reset button on the board, re - installing the software and installing all available drivers. Still get the same error. Maybe there's a problem with the board?

P.S. I use an Arduino Uno