Upload error: avrdude: ser_open(): can't set com-state for "\\.\COM17"

Hi all,

I've just recived my Arduino Uno, i plugged it in my Pc (Win 7), and when I try to upload something this is what i get:

Binary sketch size: 1026 bytes (of a 32256 byte maximum)
avrdude: ser_open(): can't set com-state for "\\.\COM17"

I tried to change the COM port but it won't work... The green Led is on The L Led is still blinking as normaly...

I tried to search on Google but i haven't found a solution

Could you help me?

EDIT: on another pc (Win 7) it works, but i'd rather use this one...

Did you check the typical first thing; what com-port appears to the list when you connect your arduino? Double check that, and try again.

Cheers, Kari

Yes, I double checked it but still not working...

You have lots of serial drivers in your computer...?

Kari

in the device manager i have only the Arduino Uno device... but in arduino program i can choose between COM4 to COM17 ports...

Ok, if you are sure that COM17 comes and goes when you connect and disconnect your arduino, then it must be so.

Cheers, Kari

the first COM that appeared in the device manager was COM3, but in arduino program i can only choose from COM4 to 17, so i changed it in the device manager... did i do something wrong?

In all my Arduino IDE in four computers, I can see only those ports that can be seen in device manager. I have XP and Windows 7 64-bit, all works alike.

You shouldn't need to change com-port numbers without a good reason.

You say that you can't see COM3 in Arduino IDE even if that is the one that pops in and out in Windows device manager?

Cheers, Kari

Yes, in arduino i can only choose from COM4 to 17...

maxidvd: Yes, in arduino i can only choose from COM4 to 17...

Can you take a screenshot of that part of the menu? Sounds very strange.

Kari

You IDE has gone grazy! :fearful:

Seems like it show everything else but actual co port. Does you device manager show COM1 or COM2.

Kari

It seems that print screen isn’t working anymore…:slight_smile:
just one minute…
EDIT:

Seems to my that your correct port is COM10, have you tried that?

Cheers, Kari

yes of course...

maxidvd:
yes of course…

Yes of course… “Yes, you have tried” or “Yes of course, I should have tried that and it works”?

Cheers,
Kari

I tried and it didn't work...:)

Ok. Then I must apologise, I cannot help more.

Does it work with another computer? If the same problem exists, then your Arduino is probably broken. Oh, I read the first post again, problem lies in your Windows. Drivers are ok?

Kari

yes it works an my asus netbook as i said before yes, the seems to be ok

(deleted)