Using a transistor in place of a switch

I have a small remote control that I have removed a couple of momentary switches from and would like to control with an Arduino. I hooked up a small transistor circuit connecting the base of a tip120 to pin 13 and connected wires from where the switch was to the collector and emitter. The remote runs on a 12V battery. And from my short look at the remote circuit the switch connected 12V to one of the pins on the remotes IC.

This seems to work, turning on the indicator LED on the remote and having the signal received by the other side. When I try to replace a second button to another Arduino pin and another transistor the circuit stops working. The remote indicator LED lights up even with the new circuit but it doesn't seem to send a signal (at least that is received by the other end).

Also both buttons will work with the circuit on their own. That is I can hook up either to the single transistor circuit and it works fine.

I had a spare relay that I replaced one of the transistors with and it works well in that setup but no go with the transistor circuit.

I am just curious if anyone has any ideas as to what is the issue. I obviously have found an alternative solution just curious what is going on. Would a different transistor be more appropriate? Perhaps a Mosfet?

Mostly curious. Thanks for any help.

Yes a mosfet is a better choice here as it is a pure resistance instead of a current device that is the transistor.
However, you have an unknown circuit at the other end so anything could be happening. How have you referenced the grounds?
This is the sort of thing that might benefit from using an opto coupler.

I have referenced the grounds and I started out using an optocoupler figuring it was the safest option first but it didn't seem to carry enough voltage across the circuit to trigger the remote, the indicator LED barely lit. I may have to check the resistor I put on it or try a different optocoupler.

Sorry thought you asked if I HAD referenced the grounds. I tried two configurations.

First I simply grounded the emitter of the transistor to the Arduino. This basically works, except for when you add a second transistor/button.
When I had issue with the second transistor/button I tried connecting the batteries ground to the arduinos ground. I figured since the emitter wasn't actually connected to ground but the input pin on the remotes IC. It was totally non functional however.

I tried connecting the batteries ground to the arduinos ground.

Yes that is what you should have done. The fact that you said it didn't work suggests you have something wrong. As does the fact that you said it worked just connecting the emitter to the arduino ground.
So with the things that shouldn't work working and the things that should work not working you have a whole lot of stuff wrong.

If you use optos you do not common the ground.

it didn't seem to carry enough voltage across the circuit to trigger the remote,

Sorry but this makes no sense, they do not "carry voltage across" that concept is wrong.