Which SIM card can use?

I am in UK, and I have bought a sim card from Soracom. But when I use the examples code, I found that I could not get the PIN number and I could not access the network. I think maybe SIM card can not use. So, I want to know which sim card can I use in UK.

A little disclaimer, I wanted to use Soracom for an NB IoT project a month ago, but their support team told me that their SIM cards didn't support NB IoT. You can only use the Soracom SIM to connect to LTE/Cat-M1.

I got a Soracom SIM from Canada for my MKR1500, but I suppose it should yield the same registration steps. As far as I know, Soracom has a headquarters in Europe, so there should be coverage for your SIM. You can view what providers and IoT technologies cover your area with this website: GSMA | Mobile IoT Deployment Map | Internet of Things.

  1. I'm supposing you already activated the Soracom SIM on their website? If not, please do so before continuing.

  2. You probably already downloaded the MKRNB library, if not, do so in "Manage Libraries..." under "Tools" in the Arduino IDE.

  3. The Soracom SIM does not have a PIN-lock by default. In the MKRNB library sketches, you can just leave the PINNUMBER field empty as it already is by default.

  4. Go in "File" --> "Examples" --> "MKRNB" --> "TestModem". This sketch allows you to test if the modem on your MKR1500 is working properly or not (you do not need to have a SIM card inserted for this example).

  5. Next up, in the same directory, load the example "ChooseRadioAccessTechnology". Since Soracom only allows LTE/Cat-M1 connection, please enter the choice 0 into the Serial Monitor when asked to.

  6. You can then load the "NBScanNetworks" example. If you've gotten this far, please post the output of this sketch (of the Serial Monitor) so we can try and figure out the problem further.

Thanks for your reply!
Here are the results I get from the "NBScanNetworks" example:
14:51:50.486 -> NB IoT/LTE Cat M1 networks scanner
Then nothing happened.
I tried to debug by using NB nbAccess(true);
The result is

14:53:42.440 -> NB IoT/LTE Cat M1 networks scanner
14:53:42.580 -> AT

14:53:42.580 -> OK
14:53:42.580 -> AT+CPWROFF

14:53:42.580 -> OK
14:53:46.989 -> AT

14:53:46.989 -> OK
14:53:47.134 -> AT+CMEE=0

14:53:47.134 -> OK
14:53:47.325 -> AT+CFUN=0

14:53:47.325 -> OK
14:53:47.516 -> AT+CPIN?

14:53:47.516 -> +CPIN: READY
14:53:47.516 -> 
14:53:47.516 -> OK
14:53:47.707 -> AT+CMGF=1

14:53:47.707 -> OK
14:53:47.923 -> AT+UDCONF=1,1

14:53:47.923 -> OK
14:53:48.142 -> AT+CTZU=1

14:53:48.142 -> OK
14:53:48.312 -> AT+CGDCONT=1,"IP",""

14:53:48.353 -> OK
14:53:48.538 -> AT+UAUTHREQ=1,0

14:53:48.538 -> OK
14:53:48.755 -> AT+CFUN=1

14:53:48.755 -> OK
14:53:48.947 -> AT+CEREG?

14:53:48.947 -> +CEREG: 0,0
14:53:48.947 -> 
14:53:48.947 -> OK
14:53:49.136 -> AT+CEREG?

14:53:49.136 -> +CEREG: 0,0

In addition, I tried AT+CSQ and AT+CESQ, the result is:

10:56:38.837 -> AT+CSQ

10:56:38.837 -> +CSQ: 99,99
10:56:38.837 -> 
10:56:38.837 -> OK
10:56:38.837 -> AT+CESQ

10:56:38.837 -> +CESQ: 99,99,255,255,255,255
10:56:38.837 -> 
10:56:38.837 -> OK

Is that mean there is no network covered in my area?

I think I've had the same problem as you before, hopefully I can help.

  1. If you go on the Soracom website, select your SIM and select "Details" --> "Historical Charts", is there any data? Has your SIM ever somehow managed to download/upload data?

  2. Have you tried messing around with "SARAPassthrough" sketch from the MKRNB library? I ask because that is what ultimately helped me in the end with my old MKR1500.

There are no Data that has been uploaded or downloaded.

I have tried "SARAPassthrough" sketch for AT+CSQ and AT+CESQ but I got the same results.

The U-blox module on the MKR1500 can be asked to show what providers cover your area. The command is "AT+COPS=?" in the Serial Monitor with the SARAPassthrough sketch.

Please note that this command can take a few minutes to generate a result. If it works, it will show lots of numbers detailing the providers in your area, please post them here. If it fails, post the error message here too.

I have tried and the result is
+COPS: (1,“234 15”,“234 15”,“23415”,9),(0,1,2,3,4),(0,1,2)

Perfect, so you do have coverage in your area. We don't know the strength of the signal but here is what we know:

With help from Google, 234 is apparently the Mobile Network Code for Guernsey (UK). The number 15 is the carrier, which seems to be Vodafone UK. Hopefully this makes sense.

What is the output from the command "AT+UMNOPROF=?".

edit: Actually, 234 is the Mobile Network Code for the entire UK.

I have used AT+UMNOPROF=19; which is vodafone. By the way here is the result.

16:22:20.954 -> AT+UMNOPROF=?

16:22:20.993 -> +UMNOPROF: 
16:22:20.993 -> 0: SW default
16:22:20.993 -> 1: SIM ICCID select
16:22:20.993 -> 2: ATT
16:22:20.993 -> 6: China Telecom
16:22:20.993 -> 31: DT
16:22:20.993 -> 8: Sprint
16:22:20.993 -> 100: Standard Europe
16:22:20.993 -> 4: Telstra
16:22:20.993 -> 21: TELUS
16:22:20.993 -> 5: TMO
16:22:20.993 -> 19: Vodafone
16:22:20.993 -> 3: Verizon

This is good, you've gotten farther than I had with my MKR1500. I'm afraid I won't be able to help with the next step(s), but I suggest you mess around with the MKR sketches and the U-blox commands with SARAPassthrough.

Keep checking the Soracom website "Historical charts" to see if your SIM has managed to upload/download some data.

If you haven't already, you can try to follow these steps, provided by U-blox at: https://www.u-blox.com/sites/default/files/SARA-R4-Application-Development_AppNote_UBX-18019856.pdf. Instead of UMNOPROF=100 you can keep UMNOPROF=19, since we know that you have that coverage in your area.

I also suggest you read the documentation in the link above if you have the time, especially section 8.

If ever I figure out the problem with my MKR1500, I'll let you know how I got my Soracom SIM working. I simply just can't get it to work for the moment.

Thanks a lot! By the way do I need to connect the li-po battery, although I have already used the USB connection to the computer.

You're welcome, hopefully I could help. For all I know, the on-board Li-Po battery isn't necessary to connect to a network. For my project I connected an external battery to the board so that it can run without a USB connection to a PC, but it isn't necessary.

Hi, sorry to disturb you again, I still have some problems with the Arduino MKR nb 1500.
First, do the Arduino MKR nb1500 or u-Blox need initializing or some registration on first use?
Second, you said there is an on-board Li-Po battery, but on this website: Arduino MKR NB 1500
The pinout diagram illustrates there is no Li-Po battery on the board. There is only one connector for the Li-Po battery to be inserted. I apologize for my bad English, I don't quite understand what you mean.
In addition, the CHRG LED will only blink when it is just plugged into the USB, after that it will never light up again. Do you know what's going on here?
Thanks in advance.

  1. From what I have read online, some people receive their MKR 1500 already configured for a network, but it is rare. I think the MKR 1500 does need to be initialized like we already did before with the UMNOPROF and URAT commands.

  2. Yes you are correct, there is no on-board battery. Excuse me, I explained myself badly.

  3. If you haven't already, you can check the meaning of the different states of the CHRG LED here: What is the meaning of CHRG LED different states in MKR boards? – Arduino Help Center. I'm currently just experimenting with different battery types and voltages, so maybe someone else could tell you a bit more about the battery usage.

I have managed to fix my MKR 1500. I followed the exact steps we talked about before and it is able to connect to a network here in Canada. However, I had to set up my Arduino outside of my house for it to actually be able to establish a connection. From my room, my Arduino isn't able to connect to the network. I'm pretty sure this is because I live in a very rural area, maybe trying from a different location would help you too?

Also, if nothing seems to be working, I remember when I started first reading about the subject online that UMNOPROF = 100 would work for people that live in Europe as it is kind of a universal european connection. I hope this makes some sense.

The only network providers AT+COPS=? showed me was Bell Mobility and Telus Mobility. I chose Telus, because my U-blox already had a UMNOPROF for that network. So technically Vodafone should work for you, but maybe give it a try with UMNOPROF=100 and following the three steps I posted earlier.

Good luck.

Thanks for your help! I think I may have found the problem. Soracom does not have LTE CAT-M1 or NB-IoT network coverage in the UK. The only network coverage in my area should be Vodafone. And I have just found that my Vodafone SIM card expired in February. So, I am trying to find another SIM card and keep trying. Thank you again!