WIFI RSSI arduino esp8266

Salve a tutti, sono nuovo del forum e nonostante è da un po' di tempo che giochi con Arduino ho dei seri problemi con l'ESP8266.

Il mio progetto è teoricamente semplice ma ci sono dei concetti di base con questo modulo che temo di non aver compreso nonostante cerchi da giorni su internet.

Vorrei fare questo: arduino Uno con ESP-01 che si connette a una qualsivoglia wifi e arduino mi da il valore RSSI.

Dubbi:

  • ho provato lo sketch seguente caricandolo su arduino
    Arduino - WiFiRSSI
    ma il monitor seriale non mi da nessuna risposta

-va bene avere il firmware originale su ESP o devo cambiarlo? e se si devo dare all'ESP qualche codice o devo fleshiarlo? (qui ho veramente confusione)

-i collegamenti TX RX vanno collegati TX - TX e RX - RX (come quando mando i comandi AT che funzionano bene) o vanno invertiti?

-ho provato a mandare qualche comando AT da arduino (Serial.print("AT\r\n")) ma vedo sul monitor seriale la scritta del comando senza avere alcuna risposta dall'ESP

p.s. alimentazione ESP l'ho fatta corretta con alimentazione separata.sistema operativo Windows.

Grazie a tutti per l'aiuto e i chiarimenti

Buongiorno,
essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione tutto il su citato REGOLAMENTO ... Grazie. :slight_smile:

Guglielmo

P.S.: Ti ricordo che, fino a quando non sarà fatta la presentazione, nessuno ti potrà rispondere, quindi ti consiglio di farla al più presto. :wink:

Da parte mia posso solo segnalarti che, in Megatopic, c'è un thread di oltre 180 pagine interamente dedicato al ESP8266.

Nella prima pagina troverai una serie di link a guide e tutorials che magari possono fornirti qualche indicazione :wink:

Guglielmo

Ti ringrazio ma purtroppo non è bastato

L'ESP-01 all'accensione dovrebbe mandarti prima un guazzabuglio inintellegibile e poi una scritta. In genere questi moduli vanno a 9600 oppure 115200, quindi per prima cosa devi stabilire qual'è la velocità corretta.