XBee wireless kit: no connection

Hello, noob here :wink:

I have an Arduino Uno (part of the starter kit). Some time ago I bought a SparkFun XBee Wireless kit containing two identical XBee modules, a shiled with headers to solder onto and an explorer USB.

I followed these two good articles by SparkFun:

I have the headers soldered and the shield put onto my Arduino. I tried some basic experiments that did not require communication (like registering a button input, lighting a LED depending on it,...) to check if the soldering worked and everything looks ok (although admittedly the soldering work was not perfect, but it seems to be good enough).

I managed to see and configure both modules with XCTU as suggested by the articles. The second article I linked proposes a very simple sketch to check if the communication works: you have one module mounted onto the shield, the other one connected to XCTU with the explorer and you should see messages sent by XCTU received by the serial console in Arduino and vice versa. Well, that does not work. I don't see anything communicated. Also, if I search for close devices in XCTU, the search does not give any results: the module on the Arduino is not found by the module attached to the explorer.

Out of the 5 LEDs on the shield, only the power one turns on (red).

I don't know what am I doing wrong here. Do my modules require an external antenna (does not seem so)? Did I solder the headers incorrectly (I tried to debug the result and could not find any obvious problems)? Are there some operations I'm missing (I followed the guides step by step)?

How can I get closer to the source of the problem and fix it?

Thanks!