Yùn reset via command line issue

Even after last firmware upgrade, if i remotely reboot the Yùn via console (command /sbin/reboot), i will lost communication until i will reboot it manually (removing power and powering again).

I tried to remove wifi-live-or-reset from /etc/rc.local I tried reset-mcu && reboot

All with no success

Tha strange fing is that after reboot the current consumed will became half, like if i will "shutdown" instead of "reboot"

Is there a workaround?

Thanx

What sketch are you running on the Arduino side?

/sbin/reset only resets the Linux processor, and does not reset the 32U4 processor. So the sketch is still running. If that sketch is sending any data over the serial port to the Linux processor, that can interrupt the boot process.

If we know more about your sketch, and why you are rebooting remotely, we may be able to come up with ideas to help. You basically need a way to stop the sketch from sending anything while the Linux processor reboots.

Read the two following articles:

1) Resetting the processors (AR9331, WiFi, and 32U4) http://arduino.cc/en/Guide/ArduinoYun#toc6

2) How to improve reboot/reset stability http://playground.arduino.cc/Hardware/Yun#rebootStability

Ok, solved with reset-mcu && reboot after adding 5000ms delay in sketch setup function. Thanx