12V Schalten mit NPN+PNP

Hallo zusammen,

für ein Projekt würde ich gerne mit einem Arduino 12V High Side schalten wollen. Leider kann ich es nicht mit rein NPN machen, da die Platine nicht verändern kann und ich LEDs (10-20mA) nicht anders schalten kann.

Evlt hat jemand eine andere Lösung.

Fakt ist, dass 12V an den LEDs (current wird mit den Widerständen onboard limitiert). Ein widerstand von GND auf 12V+ ist nicht messbar.

So sieht meine Schaltung aktuell aus:
(siehe Anhang)

Widerstände beide 1kOhm

Arduino macht alle 10sek high/low

  • Aus Sicherheitsgründen mache ich die 12V Eingangsspannung mit einer 9V Batterie. Später können am Eingang 11-14.5V anliegen. Evtl Glätte ich das auch mit FIX 12V.

So nun zu meinem Problem:
Wenn kein Load dran ist, habe ich am Ausgang des PNP 12V (9v Batt). Sobald ich den Load dazu gebe, dropt dieser auf 3.3V

Kann mir jemand sagen was ich hier falsch mache?

Ich tippe darauf, du hast die Transistoren falsch rum eingesetzt.
C und E vertauscht.

In einem Automobil hast Du viele Störungen und nicht nur Deine erwarteten 11 bis 14,5V.
Grüße Uwe

HotSystems:
Ich tippe darauf, du hast die Transistoren falsch rum eingesetzt.
C und E vertauscht.

habe es 1:1 wie im Anhang gemacht. also flache seite nach vorne und runde nach hinten

uwefed:
In einem Automobil hast Du viele Störungen und nicht nur Deine erwarteten 11 bis 14,5V.
Grüße Uwe

wie könnte ich dann mein problem lösen?

danja95:
habe es 1:1 wie im Anhang gemacht. also flache seite nach vorne und runde nach hinten

sage ich doch, ist falsch.

Sieh dir doch mal das Datenblatt an, bevor du hier deine Fehler zur Schau stellst.

danja95:
wie könnte ich dann mein problem lösen?

Indem du eine saubere Entstörung der Spannung vornimmst.

HotSystems:
sage ich doch, ist falsch.

Sieh dir doch mal das Datenblatt an, bevor du hier deine Fehler zur Schau stellst.

habe mir es angeschaut. es funktioniert ja auch wie gewollt, aber ich verstehe nicht warum nach dem hinzufügen des loads die spannung dropt. laut datenblatt kann das ding 100-160mA schalten.

HotSystems:
Indem du eine saubere Entstörung der Spannung vornimmst.

Ich meinte nicht die Spannung, sondern eine Alternative zu dem PNP (und auch kein Relais). Hätte hier einfach DC-DC Step Down Converter auf 11 Volt gemacht.

danja95:
habe mir es angeschaut. es funktioniert ja auch wie gewollt, ....

Das glaube ich dir nicht.
Deine Transistoren sind falsch und können so nicht funktionieren.
Und das schreibst du ja auch. Ohne Basisspannung darf am PNP nichts rauskommen.
Bei dir kommen aber 12 Volt (9Volt, auch diese Darstellung ist schon Mist) raus.

Ich meinte nicht die Spannung, sondern eine Alternative zu dem PNP (und auch kein Relais). Hätte hier einfach DC-DC Step Down Converter auf 11 Volt gemacht.

Dann solltest du genau erklären, was du meinst.
Diese "wischiwaschi" Beschreibungen versteht keiner.

Und es gibt keinen Stepdown-Regler der aus 11 Volt 11 Volt macht.

HotSystems:
Das glaube ich dir nicht.
Deine Transistoren sind falsch und können so nicht funktionieren.
Und das schreibst du ja auch. Ohne Basisspannung darf am PNP nichts rauskommen.
Bei dir kommen aber 12 Volt (9Volt, auch diese Darstellung ist schon Mist) raus.

habe das so 1:1 vor mir und es geht. Ich kann dir gerne auch ein Video davon machen.

HotSystems:
Dann solltest du genau erklären, was du meinst.
Diese "wischiwaschi" Beschreibungen versteht keiner.

Und es gibt keinen Stepdown-Regler der aus 11 Volt 11 Volt macht.

um das thema geht es auch eigentlich garnicht.

Was ich machen will:

Ich will mit meinem Arduino die High Side eines 12V verbrauchers schalten, der nur 22mA nutzt. Ein Relais wäre overkill. Und die kleinen Transistoren wäre genau richtig dafür.

Was ich machen will:

Ich will mit meinem Arduino die High Side eines 12V verbrauchers schalten, der nur 22mA nutzt. Ein Relais wäre overkill. Und die kleinen Transistoren wäre genau richtig dafür.

Schön!

Das kannst du ja auch so tun!

Aber, wo ist dein Problem, wenn du sagst " es funktioniert ja auch wie gewollt, "?

danja95:
habe das so 1:1 vor mir und es geht. Ich kann dir gerne auch ein Video davon machen.

Du bist ganz schön Beratungsresistent.

Sieh dir das Datenblatt an.
Da siehst du, das der Transistor immer noch falsch angeschlossen ist.

Und hier ein Auszug daraus.

NPN.png

um das thema geht es auch eigentlich garnicht.

Was ich machen will:

Ich will mit meinem Arduino die High Side eines 12V verbrauchers schalten, der nur 22mA nutzt. Ein Relais wäre overkill. Und die kleinen Transistoren wäre genau richtig dafür.

Das habe ich schon gemerkt. Du kannst nur nicht verstehen, dass da was falsch läuft.

combie:
Schön!

Das kannst du ja auch so tun!

Aber, wo ist dein Problem, wenn du sagst " es funktioniert ja auch wie gewollt, "?

das habe ich doch schon mehrmals gesagt.

HotSystems:
Du bist ganz schön Beratungsresistent.

Sieh dir das Datenblatt an.
Da siehst du, das der Transistor immer noch falsch angeschlossen ist.

Und hier ein Auszug daraus.

NPN.png

Das habe ich schon gemerkt. Du kannst nur nicht verstehen, dass da was falsch läuft.

HotSystems:
Du bist ganz schön Beratungsresistent.

Sieh dir das Datenblatt an.
Da siehst du, das der Transistor immer noch falsch angeschlossen ist.

Und hier ein Auszug daraus.

NPN.png

Das habe ich schon gemerkt. Du kannst nur nicht verstehen, dass da was falsch läuft.

wie wäre es denn dann richtig? ich habe versucht mich an dieser anleitung zu halten https://www.baldengineer.com/pwm-3-pin-pc-fan-arduino.html

Da sind wieder die Zahlen (1 2 3) wieder anders.

1 ist bei dem Base.

Sage mir bitte doch wie es richtig gemacht wird.

danja95:
Sage mir bitte doch wie es richtig gemacht wird.

Du willst nur nicht lesen.

Auch das Datenblatt willst du nicht ansehen.

Aber nochmal nur für dich, ein letztes mal:

In Post #1 habe ich dir schon geschrieben, du hast Kollektor und Emitter vertauscht.

Und wenn du dich nach Zahlen am Transistor orientierst, das ist der größte Blödsinn.
Transistoren haben Basis, Emitter und Kollektor. Was davon ist 1, 2, 3 ?

HotSystems:
Du willst nur nicht lesen.

Auch das Datenblatt willst du nicht ansehen.

Aber nochmal nur für dich, ein letztes mal:

In Post #1 habe ich dir schon geschrieben, du hast Kollektor und Emitter vertauscht.

egal wie ich NPN oder PNP drehe, das Problem, dass nachdem der Verbraucher angeschlossen wurde, die Volt Spannung fällt (auf ca. 3V) ist immer noch da.

danja95:
egal wie ich NPN oder PNP drehe, das Problem, dass nachdem der Verbraucher angeschlossen wurde, die Volt Spannung fällt (auf ca. 3V) ist immer noch da.

Dann machst du was falsch ! Oder die Transistoren sind schon kaputt.

Suche dir ein anderes Hobby.
Oder lerne Schaltbilder und Datenblätter lesen.

Ganz sicher ist, wenn du es richtig machst, dann funktioniert es.

Und als letzte Hilfe:

Zeige ein gutes Foto deines Aufbaus, auf dem alles sauber zu erkennen ist.
Ohne dem bin ich hier raus.

P.S. Die Batterie ist leer !

HotSystems:
Suche dir ein anderes Hobby.

danke, sehr aufbauend.

HotSystems:
Und als letzte Hilfe:

Zeige ein gutes Foto deines Aufbaus, auf dem alles sauber zu erkennen ist.
Ohne dem bin ich hier raus.

P.S. Die Batterie ist leer !

Habe dir die Richtung der Transistoren eingezeichnet. (direkt_verbunden.jpg)
Wenn ich die Batterie direkt verbinde, ist alles wie es sein soll.
Sobald dann die Schaltung dazu kommt, ist es nicht mehr richtig.

danja95:
danke, sehr aufbauend.

Gerne...aber du willst es ja so.

Ich weiß nicht, was du an den Transistoren verdreht hast, aber so wie auf dem Bild sind Kollektor und Emitter vertauscht.

Das kann so nicht funktionieren.

Ich sehe schon, ich rede hier gegen eine Wand.

HotSystems:
Gerne...aber du willst es ja so.

Ich weiß nicht, was du an den Transistoren verdreht hast, aber so wie auf dem Bild sind Kollektor und Emitter vertauscht.

Das kann so nicht funktionieren.

Ich sehe schon, ich rede hier gegen eine Wand.

kostet ich dich so viel überwindung mir zu sagen, dreh den Transistor XY so rum und pin 123 von links nach rechts so rum?

du siehst doch das ich das nicht verstehe. die schaltung schaltet strom, aber nicht genung. und ich verstehe nicht warum. wäre was vertauscht würde doch kein strom fließen, oder?

danja95:
kostet ich dich so viel überwindung mir zu sagen, dreh den Transistor XY so rum und pin 123 von links nach rechts so rum?
.....

hallo...ich bin mir sicher, jetzt geht es mit dir durch.

Wie oft habe ich dir geschrieben, du hast Kollektor und Emitter vertauscht.

Was verstehst du nicht daran ?

Und nochmal...ein Transistor hat nicht 1, 2, 3 sondern Kollektor, Basis und Emitter. Wenn du das nicht verstehst, tust du mir leid.
Und es kostet mich keine Überwindung dir zu sagen, du willst es nicht verstehen.

lass die Finger von der Elektronik und gehe lieber in der Sandkiste buddeln, da kannst du wohl keinen schaden anrichten.

Und ich bin hier raus...ehrlich, das ist mir zu dumm.

. wäre was vertauscht würde doch kein strom fließen, oder?

Das ist ein Irrtum!

Der Transistor tut dann nicht, was er soll, weil du ihn im unspezifizierten Bereich betreibst.
Aber das heißt doch nicht, dass da kein Strom fließt.