168 + parallel port + uisp + avrdude + boot loader

Finally working! So far…

So, you are like me, bought a 168, have a parallel port programmer (too cheap to buy a real one), and want to use it on your original adruino board, but can’t get a bootloader on it properly, check these links:

→ de-solder the LED on pin 13? worked for me

→ set the extended fuse to 0x0, not 0xf8 nor 0x7

→ how to change fuses in avrdude

I burnt the boot loader with uisp with the batch file: (edited from the original atmega8 one in the bootloader folder)

@REM parametre >>-dprog stk500 -dserial=$PORT << default
cd ..

tools\avr\bin\uisp -dpart=ATmega168 -dprog=dapa -dlpt=0x378 --wr_lock=0x3F
tools\avr\bin\uisp -dpart=ATmega168 -dprog=dapa -dlpt=0x378 --erase --upload if=bootloader\ATMegaBOOT_168.hex -v
tools\avr\bin\uisp -dpart=ATmega168 -dprog=dapa -dlpt=0x378 --wr_lock=0xCF

Then I changed the fuses with avrdude, sine uisp cannot change the extended fuse. The fuses are:

lfuse reads as C7
hfuse reads as DF
efuse reads as 0 ← if you set this to 0x7 the bootloader will be stuck in a loop, you progam won’t run!

I did need to connect a 10k resistor from RX to ground, but it worked from some people, so try it!

Hope this will help someone!


Sorry when I said "I did need to connect a 10k resistor..." I meant that I didn't need a resistor.