3G GSM Shield - American Version SIM5320A - Tinysine

Hello,

I am looking for any help that you may be able to offer,

I purchased a GSM shield off of Amazon:
3G GSM Shield - American Version SIM5320A
Maker: Tinysine

I can not get the board to connect,

  • The error code is: “No response to AT”
    “Couldn’t find FONA”

I have tried to follow the instructions from the makers website:
https://www.tinyosshop.com/index.php?route=information/news&news_id=51

The screen capture video of my issues:

Overall I am using a Arduino 2560
Arduino version 1.8.8

  • I have tried to use a software and hardware serial connection
  • I have tried multiple computers
  • I have tried to connect with or without the SIM installed
  • I have tried to connect with and without the additional 9V power

Please help,

I’m willing to try anything you can offer,

Thank you,

Joe

FONA3G_setbaud.ino (2.31 KB)

Serial Output.txt (1.45 KB)

ok, start with basics.
Antenna connected.
No code required.
No SIM card.
Power on 5V to Arduino & shield
Check modem red light is on. (5V present)
Hold power button on modem for a second
Check bluebOED comes on (modem power)
Power off.

Insert SIM card...

Repeat above.
After several (up to 20) seconds, blue LED should blink — modem has found a network to connect to...
(doesn’t mean you have SIM credit)

If you get here, check your serial connections to the modem.
(Use a different serial port than the Arduino USB D0/D1 )
There are links on the modem to select which pins are used.

The serial speed I found in all my SIM5320 has been 4800 by default.
Let’s see how you go from here.

If still not working, and blue LED is blinking, write a simple pass-through program from the serial monitor to the modem serial, and vice-versa.
Then you can try simple AT commands without FONA in the middle.
Once that works you can start again with FONA.

P.s. I use the Arduino / modem combination with an external 5V supply.
The Arduino regulator probably can’t cut it to supply the 5V for the modem. (which btw from experience draws most current when finding a network.

Please post any code within , otherwise we can’t read it on mobile devices.
Not a problem here because you haven’t got that far yet…

Solution:

I contacted the maker for help,

After they sent me the data sheet, I was able to determine the fix,

For a mega 2560 board, I had to jump the Tx and Rx to pin 12 and 13 using jumper wires.

I updated the code to reflect this change,

Afterwards, the problem was fixed,

Thank you all,

J

Hi rub_me ... looks like I am having the same issue with my 3G SIM5320A board. The AT command test and Baud rate test both fail saying FONA not found.

Could you outline the solution that you found and were able to make work?

Keen to get this up and running.

Thanks,

Matt