A question about arduino and Linux [SOLVED]

Hi There! I recently installed arduino under linux, from AUR repository and it seems to work fine. But i can't get it run under my normal user. It succesfully upload the programs to the arduino board if I execute the IDE as Root, but with my normal user, i'm not able to Select and/or use the serial usb port (ttyUSB0).

So, i think that is a permissions problem.

Could you say me tha name of the group that would allow me to manage Usb Serial ports?

Best regards

  1. Login as your user

  2. At the shell prompt, type "groups" (hit return).

This will list the groups your user is a part of. Note them somewhere.

  1. At the shell prompt, type "ls -l /dev/ttyUSB0" - this should show the permissions for the device, including which group it is a part of.

  2. Check your list of groups from step 2 - are you a part of the group?

  3. If not, you will need to add yourself to the group (provided the group isn't "root" or something like that).

  4. At a root prompt (or use sudo) type "useradd -G {group} {username}" - where {group} is the name of the group to add your user {username} to (do not include the brackets).

That should add you to the group and allow you to use the device, provided that is actually the issue. If the device is a part of a "root" group or something else, off the top of my head I am not sure exactly what you do (my gut instinct would be to list the groups in some manner, find one that is for usb - and if not, create it - than chgrp the device to that group and add my user to the group - that would be the start of it, anyhow).

Good luck, hope this helps - btw, get used to this kind of stuff, study up on linux sysadmin and such, it is very useful, looks great on a resume/cv, and you'll need it often if you are doing anything more than simple tasks under *nix (google is your friend here).

:)

You need to be in the group allowing the use of modems.
Not obvious but the usb cable works as just a serial link.

Menu - System - Administration - Groups and Users.
You will need to unlock the privileges with your password.
Look at your users properties and under user privileges.
Check the box for using modems.

Log out and back in again and you should be ok.

Gordon

Output of "ls -l /dev/ttyUSB0":

crw-rw---- 1 root uucp 188, 0 jun 17 22:15 /dev/ttyUSB0

I added my user to "uucp", and now it works!

Ty and Best regards