All axis on CNC will not move

Hello people, first I would like to say HI to everyone here as I am new to this site but not so new to Arduino.

I have had a 3D printers for some years now so I do know the basics of Gcode, Marlin and GRBL.
Another interest of mine is making pcb's so now that I have a little time on my hands I decided to build myself a cnc pcb milling maghine with the intention of running it on an Arduino Uno with a cnc v3 shield, and GRBL with Mach3 or UGS.

I am using 3x Nema 17 motors at 0.7A and 5v, and an Eleksmaker 555 spindle at 12v and 3x A4988 drivers.

So far I have tried using 2 different Uno's with the v3 shield and several different GRBL files with UGC and Mach3
2 different Nano's with appropriate cnc shield and same progs as above, and also 2 different Arduino Mega's with 3 Ramps 1.4 boards
(1 set was taken off a working 3d printer) and several versions af Marlin that have already been set for a cnc.
Then a friend sent me a copy of all the files that he uses succesfully on his own diy machine.
Guess didn't work.

So far the only movement I have had has came from the Uno/v3 setup with 1 specific GRBL file and UGS. Although it is by no way
good enough for the purpose of a double sided pcb, because the X and Y axis both jerk a little when the gcode is started.
I get nothing at all from Mach3 either, and on Marlin (with the mega), all I get is a 'KILLED Please reset' error on the screen as soon as it comes on, but still no movement at all.

My initial thought was a missing Arduino library, but all the libraries that are asked for are already installed and updated.

I would prefer to use Mach3 because of the auto level capabilities but I can't even connect it to my cnc com port.

I am on the edge of insanity now, I haven't got a clue what is wrong.
If anyone can shed any light on this problem I will be eternally grateful and in your debt forever.
Thanks in advance for any and all answers

Stay Safe,

I suggest you start by testing each motor with a simple Arduino program rather than with GRBL etc. Try the first program in this Simple Stepper Code with suitable changes for the pin numbers for step and direction for the different motors - one motor at a time.

If the motor won't work with the simple code it won't work with GRBL.


invert ENABLE

Also the 555 spindle is a cheap and nasty one with a paint job.

Some of the NANO based shields are pooched from the get go as two connections need swapping per driver.
Only about 50/50 chance there as it involves a PCB hack or a modified GRBL firmware.

Stick with UNO's and the v3 shield until you are up an running.
Bring it up one axis at a time.

Also 5 volts for the CNC shield is pretty abysmal.
12 volts 5 amps would make an OK starter PSU for light work.

When you say NEMA17 steppers with 0.7A and 5V, do you mean you are powering the A4988 drivers with 5V??

That would be a problem. 24V is more normal.

Thanks for the replies folks.

All my motors do work as I explain that I get movement in UGS. But they do also work with the example sketches as well.


invert ENABLE what ? I do know it is in Marlin though.

And @ballscrewbob

When you say about Nano shield drivers needing to be fixed, I have not heard of this. My shield has been fixed for the permanently connected step jumpers under the drivers.

I have now managed to get some movement using Ramps 1.4 and Marlin. The Marlin firmware I am using has already been modified for a cnc machine by someone else.
While the Z axis works fine, the X any Y axis will only move in the positive direction. The screen also displays 'Endstop X'

Any other ideas guys, this 1 is a real head scratcher for me.

ENABLE is the signal to enable the steppers. Usually LOW --> steppers work, HIGH --> steppers don't work. As usually all enable are wired to one pin and all steppers don't work, I suspect you have ENABLE to HIGH.