All lights stuck on. Uno.

I was working on my Uno yesterday and had a stepper motor, HC-06, and expansion shield on top of the Uno, then all of a sudden I start seeing a bit of smoke so I quickly disconnected everything. I had an ac adapter connected for power. (I've used that ac adapter many times before.) When I reconnected the Uno, by itself, the ATmega chip started getting incredibly hot and the RX TX and L lights were stuck on. I tried another ATmega chip with the same results. And now I can't see the port to send a reset. The reset button also doesn't work.

Did I fry it? Is there any way to fix it?

Any help would be highly appreciated!

Sounds like you fried the '328P (the ATmega chip started getting incredibly hot)
and the USB/serial chip (the RX TX ... lights were stuck on)

Perhaps other parts as well. Do you still get 5V and 3.3V on the power header?

I’m still getting power from 3.3v and 5v. I don’t think it’s the 328p because I have brand new backups and I tried one with the same result. It only gets super hot with the ac plug. Not the usb. But even with the usb all the lights are on and I can’t see it in the com port.

Just confirmed, I fried two 328Ps, but I think I also fried the Uno. I have another Uno that I used to verify the fried 328Ps. Since the fried Uno is still getting power is there any way that I can revive it? I have a couple of other good 328Ps.