An simple ibrary that gives errors "undefined reference to "

I've used this library in my project before - all was working: http://sebastian.setz.name/wp-content/uploads/2010/12/multiCameraIrControl_1-91.zip

The library contains examples, now I cannot even compile a example;

Nikon.cpp.o: In function loop': /home/andre/Arduino/arduino-1.0.6/Nikon.pde:29: undefined reference toNikon::Nikon(int)’ /home/andre/Arduino/arduino-1.0.6/Nikon.pde:28: undefined reference to `Nikon::shutterNow()’

I tried 1.05 , 1.06 , and 1.5.8 - no luck.

So can you post the path of where you installed the library and have you restarted the IDE since you installed it?

I downloaded the library, installed it and the Nikon example program compiles on my machine.

thanks for the info - will try to figure out what's going on. every other project is fine. - also deleted the library and re-downloaded/extracted - no sucess.

What version of the IDE did it last compile with and what version of the IDE are you now using?

Hi. Version was 1.0.5. but the problem is solved now. The problem was SpiderOak sync going bananas, it deleted multiCameraIrControl.cpp every time -SpiderOak had some nasty bugs for years.. just moved to BitTorrent Sync. - works great.