Anything odd about Serial3 on a MEGA (128)?

I have 2 Arduinos - a MEGA with a 1280 and one with the 2560. I have a GPS on Serial3 on each. It works fine on the 2560, but not the 1280. On the 1280, if I use to Serial1 instead, it works fine. Also, running a simple terminal program with TX and RX looped back works fine on the 2560 or on ports other than Serial3 on the 1280. Is there something different about the 1280 or do I just have a bad one?

I can move things around to bypass the problem; the 2560 has Bluetooth on Serial1, which the 1280 doesn't (and will not ever) have. I use Serial2 for communications between them. They share code, so I need the setups the same. But if there is something simple I need to do to get it working, please let me know...



After switching things around, results are still not good. It seems it can't receive reliably on any Serial port other than the "main" one over the USB. I had tested with things switched and it was fine. I moved the USB over to the other MEGA to apply changed software to use the different ports (and had moved the wires) and it works fine. I leave that one powered externally. I plug the 1280 back in to USB, powering it up. The GPS is now failing to be read on Serial1 and I can't data from the other Arduino on Serial2, but I can send it. Both these things were working when I powered it off. I uploaded again, just in case. that did not fix it.

The running monologue continues...

Serial2 came back to life and Serial1 shows some signs of life (not getting good data but sometimes saying there is input; it's a GPS, so there is often something there). This has me thinking signal levels. I took an LCD/input shield I had on the 1280 off to see if it was an issue of needed power, but that did not help.

EDIT - reset the board and Serial2 is bonkers again! Now it recieves okay but send garbage

yet another edit - walked away for a while. Came back and tested and now Serial2 works again. Both have just been sitting here powered on since last test, which failed.

Is there any chance you forgot to connect the grounds together? It's not enough to run Tx/Rx over to the GPS, you must also ensure it has a connection to the GND of your Mega.

The Gadget Shield: accelerometer, RGB LED, IR transmit/receive, light sensor, potentiometers, pushbuttons

Sorry, I should have included that earlier. yes I ran the grounds together. Failing to do so might account for the error with connecting between Arduinos. But that would be totally irrelevant to the problem with the loop back, the GPS and the other serial connection that comes and goes.

Right now, they work again. No changes; just decided to test it again. In 5 minutes, who knows?

Right now, they work again. No changes; just decided to test it again. In 5 minutes, who knows?

Intermittens can be a bitch to track down. Intermittens tend to be more often hardware then software. You might consider re-flowing the solder connections to all the serial shield pins, might help.