Arduino 1.8.13 wont start

I just installed Arduino IDE on my new computer and launching I get the splash screen which quickly disappears and then nothing happens.

I tried running as administrator, reinstalling and restarting, and running the debug tool does this http://https://youtu.be/IjSo1pqfthg.

You need to run arduino_debug.exe from the command line so that you can see the full output after the program exits.

Please do this:

  • Start File Explorer (AKA Windows Explorer).
  • Open the Arduino IDE’s installation folder (usually C:\Program Files (x86)\Arduino)
  • In the folder listing of the Arduino IDE installation folder, hold the Shift key while clicking the right hand button on the mouse.
  • Click “Open PowerShell window here” (or “Open command window here” if using Windows 7). PowerShell (or cmd if using Windows 7) will now open with the current directory set to the Arduino IDE installation folder.
  • Type ./arduino_debug
  • Press Enter. Debug output should now be printed to the PowerShell window as the Arduino IDE starts (or fails to start).
  • Wait for the Arduino IDE to finish starting, or failing to start.
  • Switch back to the PowerShell window if the Arduino IDE window took the focus.
  • Right click on the title bar of the PowerShell window.
  • Click Edit > Select All. This will select all the text in the PowerShell window.
  • Press Ctrl + c. This will copy the contents of the PowerShell window to the clipboard.
  • In this Arduino forum thread, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply, making it easier for us to read.
  • Press Ctrl + V. This will paste the output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.
  • Click the “Post” button.

If the text exceeds the forum’s 9000 character limit, save it to a .txt file and post it as an attachment. If you click the “Reply” button here, you will see an “Attachments and other settings” link that will allow you to make the attachment.

Hopefully that will give us some information we can use to help you with the problem.

Here it is

debuglog.txt (53.1 KB)

Here's the relevant part of the debug output:

java.io.IOException: The cloud file provider is not running

I think you'll find the solution here:

ok thanks, you just have to launch OneDrive, that worked!

You're welcome. I'm glad to hear it's working now. Enjoy!
Per