Arduino Driver Install "A service installation section in this INF is invalid."


Just got my Arduino Starter Kit with the Uno. Downloaded the IDE version 1.8.9. Followed the instructions in the Arduino Projects book to install the IDE and install the driver to my Windows 10 PC. However the driver won't install. I get the message saying, "A service installation section in this INF is invalid." The driver won't load. Looking at back forum posts, this seems to be an ongoing problem. Does anyone have a fix for this? I hope so, otherwise the kit is going back and my Arduino career will be cut short. :-)

Any help would be greatly appreciated. Thanks.

I"m having the exact same issue using Win 10. I was excited to get started when I received my new starter kit. I already installed the offline IDE version and all of the respective drivers. I then opened the box and plugged in the board, and nothing…not starting much with the starter kit as the driver does not install and get the pop-up message shown in attached photo… I have read though the installation and troubleshooting guides for drivers and window with no success.

Please let me know if there is a fix to this issue…as I may be returning my kit as well. :frowning:

Arduino_Uno_Driver Install_Win10.PNG

Windows 8-10 have driver signing / enforcement turned up by default.

If both kits are official (sounds like they are). The drivers would normally install during the IDE installation.

If this was not the case you can go to the drivers folder in the Arduino installation and install from there. I generally recommend doing this as ADMINISTRATOR or with driver enforcement turned OFF. (google)

There are multiple posts about this type of topic so i would recommend you both read the posts at the top of the forum and learn to use the search facility.

A little reading goes a long way.

There are other localised issues that may also prevent driver installation such as Computer ownership, Antivirus, Computer policy's, etc. etc.


Bob. Thanks for the reply.

OK...appreciate that I'll have to sort through 100s of forum entries to figure out which one will fix my issue. I didn't know that's what I had to do. Thanks. ;-)

I'm having such a great 'out of box' experience so far. ...and Windows 10 is great too. ;-)

I only use windows 10 as a "test box" main unit is still windows 7.

Reason I say read a little is that there are a few methods and me doing that for you is not in my remit. Almost all of us are just users like yourself giving freely of our time and experience.



"Windows 8-10 have driver signing / enforcement turned up by default." If that's the problem, then why doesn't Arduino just sign the drivers?

"If both kits are official (sounds like they are)." Mine is. "The drivers would normally install during the IDE installation." They didn't.

"If this was not the case you can go to the drivers folder in the Arduino installation and install from there." They won't install.

"I generally recommend doing this as ADMINISTRATOR or with driver enforcement turned OFF." As far as I can tell, you can't run Device Manager as Administrator. Driver Enforcement won't turn off because of security policy. Again, why can't Arduino sign the drivers?

"There are multiple posts about this type of topic . . ." Before I originally posted I did search on the topic. The only thing I found out was that this has been an ongoing problem since at least 2015. Nobody has posted a definitive fix for it.

Does anybody know if any other board manufacturers provide signed drivers? Might have to go that route, unless I just scrap the whole Arduino idea.

A1. The drivers are signed AFAIK but as I explained the enforcement features of 8-10 are much higher than previous versions.

A2. Fact that they did not install at the time of the IDE install is often subject to settings with the windows install itself. I cannot see your system so from here its almost impossible to tell why.

A3. In the grand scheme of many many thousands of users there is a minority who don't seem able to install drivers and the reasons I gave prior are just a few of those.

A4. You are not running "device manager as an admin but installing drivers. I think you may be a little confused there. Google has lots of ways to turn off driver enforcement from temporary to permanent. If you computer has a policy in place that you cannot change (educational or business computers etc.) then you should seek out your IT departments help with that. A policy is often put in place to protect a system from abuse in one way or another.

A5. There is no definitive fix as the reasons as stated can be multiple. Each fix is a case by case.

A6. It is not limited to Arduino as you can find large amounts of problems for multiple types of hardware from Mice to almost anything else you can attach to a computer. Continually getting drivers signed by MS is not a cheap process which is why so many bits of hardware don't or only go a partial route.

Arduinos like any similar board does expect a small amount of basic knowledge of both computers and electronics. If you are looking for a reason to return the kit I am afraid I cannot give you one.

Also take note that we are almost exclusively users like your self in these forums giving freely of time, effort, and experience to help others. It can be a thankless thing at times but we keep coming back. :)


Bob…no I do appreciate the help you did provide. I understand users here are all giving up their free time to help others…it’s just that I feel that I’ve tried almost every possible fix (i.e. turn driver enforcement off, Admin install, manually install drivers etc.) that have been posted in this forum related to driver issues and Windows with no success yet. I was able to see the Atmega16u2 device pop-up and install the driver for it, but that is it. I don’t see the COM port (VCP) enumerate /get initialized in Device Manager at all. Would secure boot cause an issue or Windows Defender / Firewall being enabled?

I’m trying to use the Arduino IDE and the starter kit on my own personal laptop that has what I would call a ‘standard’ 64-bit Windows 10 installation (not a business laptop or has any strong IT related restrictions on it)…the laptop was purchased from Amazon. I didn’t expect to have such a problem getting to this work…but again its Windows right? :wink:
I’ve also attached a couple photos of the Arduino board I"m using from the starter kit

I’m trying to make EVERY possible attempt to NOT return this kit…I’ve already put in about 5-6 hours of trying to resolve this driver issue and about to come to my wits end. I’m an hardware engineer and design these sort of boards for a living so I’d like to think I know what I’m doing, but maybe I’m missing something silly here…anyway I’ll continue working on it over the weekend. I have another Arduino board (i.e. Nano) at work that I may try as well to see if I have any luck. I know that one works…

Here's what I've done lately:

  • I have tried to install the drivers on 3 different Win 10 computers. They all fail.
  • On one PC I have disabled the driver signature enforcement. Still no luck.
  • Uninstalled the software and tried reinstalling the Arduino file as administrator on that computer. Nope.
  • Tried to right click install every file in the drivers folder. Still nothing.

The weird thing is that, when I reinstall the software after the initial install, the PC tells me that it can't even find the drivers.

Another thing, ingineer_74 says that the device is an Atmega16u2, but the chip itself says it is an ATmega328 P does that make a difference? I can't find any reference to either of those designations in the drivers folder.

I'll keep trying, for a little while longer anyway, but hopes are dimming. I really wanted this to work. Thanks for the suggestions, anyway.

BTW, following are the instructions to disable drive signature enforcement, if anyone is interested:

Perform these steps to disable the driver signature enforcement in Windows 10:

a. Go into Settings-->Update & Security.

b. Then click on the "Recovery" option on the left hand side.

c. Once selected, you will see an "Advanced startup" section appear on the right hand side. You will need to click on the “Restart now” button. The PC will immediately restart.

d. Once your Computer has rebooted you will need to choose the "Troubleshoot" option.

e. Then head into "Advanced options."

f. Then "Startup Settings."

g. Since we are modifying boot time configuration settings, you will need to restart your computer one last time.

h. Here you will be given a list of startup settings that you can change. The one we are looking for is “Disable driver signature enforcement”. To choose the setting, you will need to press the F7 key.

Hello krasnejv:

I believe the Atmega16u2 identifies the small USB-to-UART interface IC on the board...look at the photos of my board in my previous post. It's the small chip close to the USB connector. I suspect Arduino may have changed to this chip or they also use the FTDI USB-to-UART chip on other boards?

It allows the Windows PC to communicate with the ATmega328 processor that is main processor on the Arduino starter kit board.

The is where the driver installed for that chip but my issue is the VCOM port for the USB is not showing up at all during my install...therefore I'm about half-way there. I may try another USB cable but doubt that is the issue since it was cable straight from the kit.

Hi ingineer_74, thanks for clearing that up. I should have realized that it would be USB related (DOH!). Do you have a file named Atmega16u2 anywhere in your drivers folder? I don't, so maybe that's why its telling me that it can't find the driver.

Hi krasnejv:
No, I don’t.

I think the actual driver that the Atmega16u2 is tied to is one of the libusb0.sys files in the \arduino\drivers directory. (see attached photo)

However, what I don’t know is exactly which one Windows may have used since it is in three different sub folders (amd64, ia64 and x86…unless they are all the same) Since I have a 64-bit installation for windows, I haven’t confirmed whether or not those libusb0.sys are the same as they are in different folders based on 32-bit and 64-bit installs.

Other than having to do a clean install of windows or other complex workarounds, it seems VERY unfortunate to have to do for such a small device. I’m not there yet…I haven’t given up. I’ve been working on this pretty much all day today…as I just received my new kit yesterday evening.


Hey ingineer_74,

I have made some progress also. I was able to download and install the Atmega 16U2 driver using an app I found called Driver Toolkit. However, I think I have the same problem that you have in that the PC didn’t assign a COM port (see attachments). DMgr says the device is working properly, but the driver doesn’t show up under the Ports & LPT section. I’m stumped again.

Driver Location in Device Mgr.JPG

Driver Properties.JPG

No Port.JPG

Hey krasnejv:

Alright…good news…we’re now both stuck at the same place now. lol :slight_smile: That is exactly how far I got…ATmega16U2 driver working, but my Windows 10 laptop does not assign COM port.

I’m now looking at the PDF document that Bob has posted on some of one of the other driver issue posts that cleans the registry when attempting to try other fresh IDE / driver installs. Not sure it will help and may end up the same place as before…but I’m willing to remove all the previous drivers and start again. (I’ve attached it here for reference.)


ingineer_74, thanks for sticking with it. I am going to hang it up for the night. I'm going to be busy pretty much all day tomorrow, so I'll probably pick it up again on Sunday. Take care.

yep, same here...will try to look at it some more on Sunday evening.

this may be another thing to try but involves a little solder work or applying short/jumpers to the board...not sure if that's what's going on and seems really far-fetched.

Both of you please step away from the soldering irons LOL.

As neither of you have got to a programming state yet there is almost zero chance you need to start to play with DFU.

Those types of step are last resort after an errant sketch or corrupted bootloader was pushed to a board.

Thanks for helping each other out btw that's the whole idea of forums.

I need to catch up on where you are.


I have a question for @krasnejv and @ingineer_74: There are three different downloads of the Arduino IDE for Windows:


Which one are you using?

The reason I ask is because I want to try to reproduce your problem with the driver and I want to make sure I set up my system the same as you.

I used the top one, the Windows Installer. But I have been considering wiping the installation and using the zip file to manually install to see if that changes anything. Haven't done it yet though. Thanks for the interest in our problem.

The win 10 “APP” has been known to cause issues for people.

Not been able to re-create the issue here either.

BTW for anyone who is doing a new install there are some clean up instructions attached.