Arduino fio doesn't power up!

My arduino fio doesn't power up I know that the usb port is only for charging. When I plug in the usp the charging led lights up. But when I power the arduino with a standard 9V battery it doesn't show me the on led glowing, and nothing happens. I checked the on-off switch that's not the problem and the battery powers up an arduino uno good what could me the matter?

  1. Why did you post this in Programming Questions?
  2. Please tell me you are not trying to charge your 9V with the FIO. (It can only charge Lithium Polymer batteries.)
  3. What points are you connecting the 9V battery?

Aww sorry I did it by mistake. No I do not intend to charge it. I am connecting the battery to the holes just after the Lipo port. (I dont have an lipo plug) There are two hole +ve and -ve accordingly I am connecting the battery

Are you connected in the right direction?

What does the 3V3 pin measure when the battery is connected?

9v is pretty high for the FIO. Look into picking up a 3.7v LIPO:

https://www.adafruit.com/products/258&zenid=1ac29ba59f3baa1c1110e21e1e052094 http://www.sparkfun.com/products/341

The FIO has a charge circuit built in, so you can charge via USB.

There is really very little indication that the device is running when it's on - the LEDs do not come on just because its powered up. Note that you do not need a battery when you are connected with an FTDI cable (you did pick up an FTDI cable to upload sketches to it, right?) Connect the FTDI cable and try to upload a sketch.

Suitable cables:

https://www.adafruit.com/products/70&zenid=dd0b253032f1f334a5e799b562dadd54 https://www.adafruit.com/products/284&zenid=dd0b253032f1f334a5e799b562dadd54

Be wary of ebay knock-off cables, I fried my first FIO with a cheap cable.

As it's given on the arduino website fio can handle upto 12 v... so 9 v is not the problem.. My brother had an fio before I have programmed it via xbees so I know about programming. I know about FTDI cable presently I use a ftdi to usb for xbees to connect it to my pc. The 3.3 v measures approx. 4 v

Yes, it can handle it, but the voltage regulator will run quite hot. You're powering a 3.3v device with 9v. Just a suggestion.

No offense was intended - please don't take my suggestions as such!

Have you tried uploading a sketch to the device when just powered via the FTDI cable? The only time I see any LED activity on my FIOs is when I'm uploading a sketch or when charging.

Yes I tried doing that by xbee's. but not by FTDI. I dont have one now. By the way what was the packing over your fio when you bought it? Mine was just in a sealed plastic bag. I will give FTDI a try mostly today itself. Then post what happens

shaunak1234: Yes I tried doing that by xbee's. but not by FTDI.

I never have gotten that to work correctly for uploading sketches, but I use series 2 XBees. But that's another topic...

shaunak1234: By the way what was the packing over your fio when you bought it? Mine was just in a sealed plastic bag.

I've purchased several - a few from SparkFun and a couple of clones from DIYBin (http://www.diybin.com/products/DFRobot-DFRduino-FIO.html). The prices on the latter are a bit lower, but shipping to the States took a seriously long time. Sparkfun was their typical excellent packaging, FIO on antistatic foam in a static bag. I believe the DFRobot clones were well packaged too. Really depends upon your vendor.

For me I have programmed fio with xbee's before.. About the ftdi I just tried it with a friends cable. and nothing happened. Now I am really tired, I have now wasted 3-4 days from 9am to 9pm just to figure out whats going wrong. :astonished: Can the fio itself have some defects in it?

shaunak1234: Can the fio itself have some defects in it?

Absolutely. The device may have been DOA, or you may have inadvertently fried it by connecting it improperly (we've all done it - you'd hardly be the first person ever to kill a component by wiring it up wrong :P) Chalk it up to experience and pick up a new one - it's all part of the learning process.