Arduino IDE 1.8.2 won't start

So, like many people apparently, i am not able to start the arduino IDE (version 1.8.2). Sometimes i see an arduino screen which almost immediately disappears again, and sometimes nothing happens. I have Windows 10 as OS, i have tried compatibility mode for windows 8, but that doesn't work. I have installed JRE 7 Update 80, which worked for some people, but not for me. The main language is Dutch in my OS,not English(some people said that actually made a difference, haven't tried it yet). So i ran out of solutions. Please help!

Have you tried running the "unzipped" version of the IDE ?

Also try turning off any security you have such as antivirus etc as reports about issues with slow compiles and failing to start can also stem from that side.

Are you just a "user" of that computer as some have also reported "run as administrator" or "install as administrator" also works.

Ballscrewbob i am the only user of this laptop. The only effect 'run as administrator' had, was that the computer asked me if arduino.exe was allowed to apply changes to my computer(Which it didn't do before). When i click yes, the arduino appears and disappears again. I tried it with both the installer and the unzipped zip file if that's what you mean? Turning off antivirus doesn't make a difference, same issue.

You can get some more information on the cause by running arduino_debug.exe from the command line and then examining the output. I find it a bit hard to understand but sometimes it provides a clue.

You could try running the IDE in portable mode following these instructions: https://www.arduino.cc/en/Guide/PortableIDE That's just a workaround, it would be better to find out why it's not working in standard mode.

I recently had the same problem and my fix was setting "_JAVA_OPTIONS" to "-Xms512m -Xmx1024m" in the Environment Variables in Windows.

since this is such a persistant problem, why not offer a list of compatable software that actually works ?

I have tried unsuccessfully to get the IDE to work on my windows PC’s
XP, 7 , 10, home, office, professional…
I have bought a new PC, bought pre-owned from E-Bay.
and I have not been able to get the IDE to run for over 2 years now.

My last use was in the fall, on an old, e-bay special I got for $100.
when it died, I tired again to get the IDE to work.

the best recommendations have been to use Linux.
but, alas, Linux has branched or forked and that is now not working.

for all the effort to make a fancy program that only works on the developers computers, I would offer the same advise I did back in the 90’s for a developer.
get the most commonly used computer and OS that your target audence uses.
develop on that and NEVER get anything more than 3 generations newer than the new stuff on the market.

another suggestion is to have a txt file of the attempted start of the IDE. that way, instead of a flash of a window that is too fast to read, the text of the failures can be gone over in detail.

Hi Dave...

Odd As I have been able to use the desktop IDE on a large variety of windows platforms as a NON DEV and as a tester.

You totally neglected to include much detail at all so I take it help is not required.

The only thing I can see right now from a selection of posts is that there does seem to be some form of JAVA issue for a minority of people (albeit there should not really be a minority either)

My take on things and I hope I am not wrong is that things must move along somehow otherwise we would still be all using DOS / CPM or some such OS.

The desktop IDE AFAIK will still work on XP, VISTA, WIN 7, WIN 8, WIN 8.1 and WIN 10 (and a few server platforms too from my own experience) So that would put the last at the WIN 7 mark (My own preferred platform).

There is also the REPO that contains older versions of the IDE too which should take compatibility even further back than the last 3 win OS.

I probably didnt say anything you didnt already know though. ;)

dave-in-nj: I would offer the same advise I did back in the 90's for a developer. get the most commonly used computer and OS that your target audence uses.

I agree. Many developers use Linux primarily but the majority of the users are on Windows. Windows support and testing is done grudgingly, if at all. Even with comprehensive testing, the "go to" operating system will always get a little extra attention since it's what they're using on a daily basis. This has caused me to stay with using Windows at several points where it would have made sense for me to switch to Linux. I'm in the process of updating my systems to Windows 10 now and I've never wished more that I had gone the Linux path so I definitely understand why people would avoid using it when possible.

dave-in-nj: another suggestion is to have a txt file of the attempted start of the IDE. that way, instead of a flash of a window that is too fast to read, the text of the failures can be gone over in detail.

You just need to run it from the command line. Unfortunately we've gotten to the point where the average computer user doesn't even know what a command line is so this certainly could be made easier. This Windows batch file run from the Arduino IDE installation folder will do it without needing to go to the command line:

arduino_debug > debug_output.txt

Thanks to pert for including the command line info of arduino_debug > debug_output.txt!

I couldn’t find the batch file in the Arduino install folder, but I know just enough about DOS to make myself dangerous… so I struggled, but was able to figure out how to run arduino_debug.exe from the command line and I found a hint in the log file that allowed me to solve my problem – so thanks for making that suggestion!

My problem was that I had tried to get ATTiny running and it broke my Arduino installation in other ways too. The log file from arduino_debug.exe showed me that it couldn’t find a file related to ATTiny. I thought I had purged every bit of it from my computer, but there was one piece left.

It’s a shame that who ever created arduino_debug.exe didn’t go just a little step further and have it create a log file when running it from Windows. That should be a little Windows tool that they make available. But whatever, it’s working normally again and I’m a happy camper.

By the way, a Windows 10 update turned on their new feature of 'controlled folder access' (which is supposed to prevent ransomware takeovers of your computer). That prevented me from saving files in Arduino even when I was running it as administrator! (Which I had to do because it wouldn't start otherwise). And Windows was giving cryptic errors mentioning java so that didn't help the confusion. It took me half a day to track down that little gem.

callmebob: I couldn't find the batch file in the Arduino install folder

Sorry for the confustion. I didn't mean to imply there was already a batch file. I meant you could make one.

callmebob: a Windows 10 update turned on their new feature of 'controlled folder access' (which is supposed to prevent ransomware takeovers of your computer). That prevented me from saving files in Arduino even when I was running it as administrator!

I recently upgraded to Windows 10 and have run into that restriction a few times already when I'm trying to tinker around with files in the Arduino IDE installation folder. It might be related to the UAC setting. I have mine at the highest setting. For that reason it might be problematic for Arduino to make arduino_debug.exe write a log file to the installation folder. They could make it write to the Arduino15 folder but that's not easy to find for a lot of people because it's in a location Windows hides by default.

FWIW, I have been using a portable install of 1.8.5 on a thumb drive for many weeks. I have been running it on Windows 10 on two different machines without issue (my hope laptop and my work desktop).

Today it would not launch. The splash screen popped up for a second then went away with nothing appearing in Windows Task Manager (not even for a second).

Went to a CMD prompt, entered arduino_debug.exe and found this:


[note that everything listed to this point was found without errors, so I don’t list what worked, just the error below]

Initializing packages…
java.io.IOException: The file or directory is corrupted and unreadable
at java.io.FileInputStream.readBytes(Native Method)
at java.io.FileInputStream.read(FileInputStream.java:255)
at com.fasterxml.jackson.core.json.ByteSourceJsonBootstrapper.ensureLoaded(ByteSourceJsonBootstrapper.java:489)
at com.fasterxml.jackson.core.json.ByteSourceJsonBootstrapper.detectEncoding(ByteSourceJsonBootstrapper.java:126)
at com.fasterxml.jackson.core.json.ByteSourceJsonBootstrapper.constructParser(ByteSourceJsonBootstrapper.java:215)
at com.fasterxml.jackson.core.JsonFactory._createParser(JsonFactory.java:1240)
at com.fasterxml.jackson.core.JsonFactory.createParser(JsonFactory.java:802)
at com.fasterxml.jackson.databind.ObjectMapper.readValue(ObjectMapper.java:2796)
at cc.arduino.contributions.libraries.LibrariesIndexer.parseIndex(LibrariesIndexer.java:93)
at cc.arduino.contributions.libraries.LibrariesIndexer.parseIndex(LibrariesIndexer.java:79)
at processing.app.BaseNoGui.initPackages(BaseNoGui.java:505)
at processing.app.Base.(Base.java:261)
at processing.app.Base.main(Base.java:144)

So, corrupted file(s) have broken my install.

I unzipped the copy of 1.8.5 I keep around (so I don’t needlessly waste Arduino.cc bandwidth) on top of the existing install and I’m back up and running.

I suspect the corruption is likely due to me removing the drive without “ejecting” it.
The other possibility is that the drive is getting old, or it doesn’t like being carried around in my pocket, static shock, etc.

I had this exact issue with Win10. Clicking on the Arduino icon would flash the Arduino screen but not load. A reboot of the computer fixed it.

If you use Arduino IDE in Dual monitors and then use it in just one monitor, you will not be able to open it. Not even reinstalling the software. When you run it again in the dual monitor environment it will open, so you can move the window to the primary monitor again.

Going to C:\Users\user\AppData\Local\ and deleting the Arduino15 folder solved the problem for me.

I was using dual monitor

I had excalty the same problem. I updated to the latest version and then Arduino IDE would start but I could not get the Arduino window to be displayed. The arduino process was in running mode in the task manager. After trying re-instaling, rebooting, using the zip installation and woodoo, I removed the Arduino15 folder ... and miracle :-)

Thank very much camilov87 !

Hello, I have installed Arduino 1.8.12 from arduino website today, installation was snccessful all drivers

installed sucessfully but the difficult part is that when i started the IDE it opens for a few moment then

closes by itself, i tried almost all the steps in the earlier form,

The same IDE works well with windows 7 but i need to run it in Windows 10.

How can this be solved?

Hello, I have managed to solve the problem , i noticed that earlier it was installed in Program FIles(x86) folder, later i uninstalled and changed the directory to C:\program Files\arduino

When i strted it worked..

Thanks for all the help

I am not sure if is the same problem, in my case i try to open de Arduino IDE, it starts normaly with the initial screen, but sudenly disapear. the solution was to delete folder arduino15 in C:\Users\USER\AppData\Local\Arduino15 i deleted it and i could open my IDE, but it automaticly recreated the folder arduino15, but in this time still continue working. but i dont know how some other files and folders are createde inside this ARDUINO15 folder, and it stops to work again and i have to delete again, i still researching why????