Arduino IDE caching library


Issue: I am modifying a library's source code (.cpp/.h) and the changes are not taking when I do a Verify in my sketch.

Workaround: Re-add library works but is painful

Arduino IDE version 1.8.13
Windows 10 64bit
Library is CircusESP32Lib (excellent data logging service from

Background: I originally added the library via Sketch | Include Library | Add .ZIP Library... and it appears in my libraries folder along with other libraries I have added. My sketch and the library has been working great on my ESP32. I now want to modify the library code (add constructor) and my sketch code to use the constructor. However, the compiler errors saying it could not find the new constructor. If I rename the library folder, update its version, and re-add the library via Add .ZIP Library... then the library change is picked up and the compile works. However, the next change I make to the library doesn't take like before.
Is there a better way?

I've tried:
Restarting Arduino IDE
Deleting the library from my libraries folder (still compiles)
Deleting cache dir from %appdata%/Local/Arduino15/
Setting cache.enable=false in preferences.txt
Changing board type


One way to do it is to temporarily move the library into your sketch folder and changing the #include <library.h>
to #include "library.h"
The library .h and .cpp files will show up as tabs in the IDE so you can edit them in the same window as your sketch.

That works really well. Thank you John!