Arduino IDE ESp32 import Serial

Hi to all, sorry to post this error here but I can’t do it in the installation/troubleshooting
forum (if you can move this thread to the correct forum please do it.
Im using Arduino IDE on opensuse tumbleweed , I just buy the esp32-cam and tried to compile the camwebserver to test the board but this error is displayed:

Arduino:1.8.13 (Linux), Tarjeta:"ESP32 Wrover Module, Huge APP (3MB No OTA/1MB SPIFFS), QIO, 80MHz, 921600, None"











Traceback (most recent call last):
  File "/home/gaston/.arduino15/packages/esp32/tools/esptool_py/2.6.1/esptool.py", line 37, in <module>
    import serial
ImportError: No module named serial

I found lots of this error on differents forums.
What I tried so far:

  1. pip3 install pyserial
  2. pip install pyserial
  3. in the bashrc i put the alias python=python3
  4. github opensuse solve error
  5. I belong to the dialout group
  6. check permission

How can I solve this problem?
Thanks
Gastón

I am intensely curious, how do you debug code when you are not given the code to debug?

And you might have much more luck with using the word Serial instead of the word serial.

idahoWalker, if you read the first lines i says that I can't post in the correct forum (troubleshooting) because the button to start a new thread is not visible to me for some reason.
This is a problem related to ESP32 and pythonwith Arduino IDE (im using 1.8.13). The first lines says something like "move to correct forum". So if you cleary see that this is nothing related to software you are wellcome to move it.
Thanks

Serial and not serial.

for those with this error:

remove symbolic link with python 2

gastón

Hi,

#> python -V

Python 3.9.0

#> pip3 install virtualenv 
#> mkdir ~/venv_arduino
#> cd $_ 
#> virtualenv .
#> source ./bin/activate
#> vim ~/Library/Arduino15/packages/esp32/hardware/esp32/1.0.4/tools/esptool.py

Change:
#!/usr/bin/env python
to
#!/usr/bin/env python3
Install arduino-cli: Releases · arduino/arduino-cli · GitHub unzip and copy to /usr/local/bin/andruino-cli
Go to your sketch folder:

#> cd ~/code/adruino/esp/projektX

Compile your Code and deploy to Board:
-b is the fqbn. in this example "esp32:esp32:esp32". Change this to your Modelname

#> grep name ~/Library/Arduino15/packages/esp32/hardware/esp32/1.0.4/boards.txt
#> arduino-cli -b esp32:esp32:esp32:PSRAM=enabled,PartitionScheme=huge_app,CPUFreq=80 compile --verbose
#> arduino-cli -b esp32:esp32:esp32 upload --verbose -p /dev/tty.usbserial-A50285BI

Press the reset button on your esp32 board and have fun.
cya