Arduino Keeps Dying when connected to WS2811 LED Strip [SOLVED]

Hello,

I have bought a set of Addressable WS2811 RGB LEDs which I wanted to control with an Arduino.

I used an Arduino Uno which was powered by 5V 1A adapter and the LEDs were directly powered by a 12V 1A adapter. The data cable from the Arduino is connected to the data input of the LED with a 330-ohm resistor, and the GND of the LED is connected with the GND of the board and the last is connected to the 5V on the board.

I used an example blink code from the FastLED library to test the blinking on the LEDs. This worked fine but as soon as I switched off the circuit and connected my Arduino to the laptop to transfer a new code, the laptop couldn’t detect the Arduino at all. This code was shown

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

And the Arduino isn’t being detected at the port.

I took the arduino to the shop and they told me the chip is fried. I tried again with another UNO and the same thing happened.

Please check my circuit and Advice on how i should proceed and what am I doing wrong.

I am attaching my circuit diagram below.

Solution
I had connected the 12V from the LED to the 5V pin on the Arduino. Both were powered by the 12v and 5v respectively hence I burned my Arduino.

Hi,
Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html

OPs Diagram,
c615cb6414dddccbc6cf8ab4d1d3b627c0a71c53.png

Tom… :slight_smile:

Hi

You shouldn't connect the 5V from the Arduino to the 12 V of the LED strip.

This page should include all the information (and probably much more) you need to understand how to wire your strip:

Hi,
Is the 12V supply providing the power for the 5V supply to the 2811 strip.
What are you using to convert the 12V to 5Vdc?

If so then you do not need the 5V connection from the UNO to the strip, just gnd and the signal.

If you are supplying the UNO with 5V through the DC socket, then it will not work, the DC socket needs at least 7 to 9Vdc to provide power to the on-board 5V regulator.

Can you please tell us your electronics, programming, Arduino, hardware experience?

Can you post a picture of your project so we can see your component layout?

Thanks.. Tom.. :slight_smile:

larsgregersen

Do you mean I should have only connected the data cable and GND cable from the Arduino to the LED strip ?

Tom

The 12V is providing power to the LED strip
The 5V is providing power to the Arduino
The arduino and the LED are although connected together with a jumper cable going to the 5V on the arduino strip( The red wire in my diagram). Was that my mistake?

And should I power the UNO with a 7/8 V power supply? The vendor here advised me to use the 5V power supply hence I used that.
Also is there any way I can repair my arduino?
I have very basic electronics/hardware knowledge and no programming or arduino knowledge.
Thanks for all the help guys.

Your pictures are not showing-up on my browser but yeah, it looks like the 5V (red wire) is the problem. You're probably feeding 12V back into the Arduino and frying it.

...It happens to everybody! It happens to hobbyists, and it happens (less frequently) to professional engineers. The difference is, if you're an engineer you've usually got extra parts and a budget. I always buy extra parts, and most parts are inexpensive, so it's usually not a big deal. But, it's a bummer when you fry something more expensive like an Arduino.

Also is there any way I can repair my arduino?

If you have the "regular" UNO with the ATmega chip in a DIP socket you can try replacing it. But make sure to buy a Arduino chip pre-programed with the bootloader. (You won't be able to program a blank ATmega chip via USB.)

It's possible that you've got other blown components on the board so replacing the microcontroller chip may not fix the board. It's probably worth the gamble... If it works you've can repair your Arduino boards and if it doesn't work you've got an extra chip (or two). ...If it was me, I'd order another Uno board and two extra chips. (And be more careful with your wiring next time.)

rishavp:
Do you mean I should have only connected the data cable and GND cable from the Arduino to the LED strip ?

Yes - you now bring 12V directly to the Arduino. That kills it.

And should I power the UNO with a 7/8 V power supply? The vendor here advised me to use the 5V power supply hence I used that.

If you have a 5V supply, you connect that to the 5V pin, not to the barrel jack (which is for connecting 7-12V supplies, which in turn gets regulated down to 5V).

Also is there any way I can repair my arduino?

Most likely not. At least the processor will be damaged, depending on your board you may be able to replace it (some boards such as the Uno have the processor in a socket), but maybe other parts of the board are gone, too. Not worth the effort.

!(Updated Arduino Circuit - Album on Imgur

Will this work?)

Looks good to me.

Hi,
What voltage is your LED strip?
5V or 12V.
Can you post a link to where you bought them please.

Thanks.. Tom.. :slight_smile:

Hey Tom,
The WS2811 strip takes 12V.
I bought them at a physical store so I can't really find pictures of this online.

Please check your img tags: you miss the / in the closing tag.

Diagram from post#7 seems correct, assuming you have a 12volt/1Amp regulated supply.
The strip shown in post#10 could use 20*0.06A = 1.2Amp full white, so careful with max brightness.
Power the Arduino from a separate source (e.g. USB) for now.
You can connect 12volt from the strip later to the V-in pin, to power the Arduino from the strip supply.

Note that a 12volt strip has no individual LED control, only control per three LEDs.
So set the number of LEDs in the sketch to 20 instead of 60 for the strip on the image of post#10.
Leo..

Hi,
In fact ATTACH your image file rather than rely on an off forum location.

OPs LED strip.
3G7WF7I.jpg

Tom… :slight_smile:
PS.
Use this to insert images.
imge.jpg

Hey, Tom, I tried attaching the pictures but they aren't showing up on my browser so I have given links.
I am reattaching the picture how you have advice. If you can see it then do tell me, must be a problem with my browser.

No - your tags are wrong - see #11.

Thanks a lot, people, removing the 5v to 12v wire worked. Really appreciate all the help.