Arduino Mega : detecting as Unknown device

Hi,

I know there are several posts with the same issue. I read many of them but couldn’t find a solution.

I’ve an arduino mega that I bought as a replacement for my arduno mega & RAMSPs 3d printer controller.
But when I connect it to PC, it’s getting detected as an unknown device.

L LED on the Mega is blinking(I think it’s the pre-loaded program)

Summary of what I’ve done so far;

  1. In several posts I read, first suggestion was to check USB cable. I’ve three of them and tried with all. I’m 100% sure that my cables are working, since I use same cables to program my LPC1768 using a J-Tag

  2. I tried connecting it to 3 PCs, all showing same error. All of them where running on Windows 8, but I don’t think that would be an issue(?)

  3. My Mega is clone one, using CH340G as USB TTL instead of FTDI chip. Like I said I previously had a same clone MEGA and It was working fine until it stopped detecting (I will tell about later in the post), so the driver was already installed, though I reinstalled it by following this video on Youtube. But got the notification as the best driver for your software was already installed.

  4. My next guess was faulty USB TTL chip(CH340G). But I read in stackexchange that, if the USB TTL is faulty the micro controller won’t work. but my L led is bling(blinking with small delay)

Is there any way to check the USB TTL chip?

I read a post somewhere( I can’t find that link) about testing the chip, but it would require a ICSP header for the USB TTL provided on the board, which is missing in mine.

Story of my previous board;

Arduino mega with RAMPS 1.4 was used to control my 3d printer. One day, when I turned the power to the RAMPS on(12 V), RAMPS shield was on top of mega, with USB connection established between MEGA and PC, It turned my PC OFF suddenly. I think some spike went through USB cable to PC and caused it to turn OFF as a protection. But After that I couldn’t make connection with MEGA. Also the controller part heats up when I connect it with RAMPs shield and turn the power ON(12 V).
I bought above board as a replacement one.

I think I damaged it’s CH340G chip or controller it self on my previous board. Is there any way to check it???

Thanks

Hi there!

When a USB cable is plugged into your board and computer, the computer powers the board. When you turned on the power to the printer, it also tried to power the board, which most likely fried the communication chip. Some genuine models have protection circuits to prevent this, but clones do not always have this in order to reduce cost.

Since you said that when the board is powered the LED is blinking, the ATMega2560 chip could still be functional, but the converter chip is probably dead. If you can replace the chip, great, however you would have to find a chip that already has the proper firmware for operation with the Arduino IDE. Normally you could preload the firmware using the ICSP header, but you said your board does not have that for the communication chip.

That being said, it may not be worth the effort to try and repair the board. You can upload sketches to the main chip using its ICSP header (if it has one) and use the USB port just for powering, but the serial communication may not be possible anymore.

Good luck!

Thanks for the reply

I was thinking about just replacing the CH340G chip.
Is there any firmware for this chip? This just a serial to USB converter right?? I've to buy one and replace it, right?
I've once replaced FT232 in TinyG and it worked.

About the blinking L led. It's only in the new board. My old board has Marlin running on it. In that if I press reset L led just turn ON and OFF; no continuous blinking

Can I just buy one chip and replace it?
And I need the USB communication part. It's not only about uploading the sketch, but also my 3D printer communicates to software using USB