Arduino Mega

Hi Es geht um folgendes ich möchte die interne pull ups aktivieren bei meinem Arduinomega Ich will einen LED Cube steuern das Problem ist das wenn die Säulen(Anode) auf low Schalte, gibt es eine verbindung zu Masse und irgendwelche Leds leuchten die nicht leuchten sollen.Ich weiß das der Atmega128 interne pull ups hat nur find Ich nirgends eine Beschreibung wie ich diese Aktiviere

http://arduino.cc/en/Main/ArduinoBoardMega

Input and Output

Each of the 54 digital pins on the Mega can be used as an input or output, using pinMode(), digitalWrite(), and digitalRead() functions. They operate at 5 volts. Each pin can provide or receive a maximum of 40 mA and has an internal pull-up resistor (disconnected by default) of 20-50 kOhms. In addition, some pins have specialized functions:

das war alles wars ich in der Beschreibung gefunden habe. MFG

Hi,

pinMode(5,OUTPUT); digitalWrite(5,HIGH); //pull up aktivieren

Fertig.

Danke für die schnelle Hilfe, suche schon seit Tagen dannach.

Gern geschehen :slight_smile:

Hallo alle zusammen Entschuldigt wenn ich mich einmische und alles kaputt mache =( =(

[s]pinMode(5,OUTPUT);
digitalWrite(5,HIGH); //pull up aktiviere[/s]n

ist falsch. So setzt Du einen Ausgang auf HIGH. Ein Pullup Widerstand wird aber bei Eingängen verwendet. richtig ist also

pinMode(5,INTPUT);
digitalWrite(5,HIGH); //pull up aktivieren

@Mysto1 Nur ist das nicht die Lösung Deines Problems. Du hast einen anderen Fehler, daß die falschen Leds leuchten.

Wenn Du die Anoden mit den Säulen verbunden hast und die Kathoden mit den Ebenen, dann gibst Du LOW an eine Fläche und die anderen Flächen auf HIGH. Dann legst Du HIGH auf diejenigen Säulen an deren Kreuzpunkte die leuchten sollen. Danach das gleiche für die nächste Ebene. usw.

Grüße Uwe

Inzwischen hab ich auch die offizielle Quelle gefunden: http://arduino.cc/en/Tutorial/DigitalPins