Arduino Micro appears, disappears, then reappears as unknown USB IO Board

I've spent several hours trying to get the Arduino Micro to be noticed by the Arduino IDE. Shortly after hitting the reset button on the board, Tools > Serial Port will show COM5 (the port my machine is using) briefly. At the same time, the Micro shows up correctly in Windows Device Manager. After a couple seconds, COM5 disappears from the Serial Port list and device manager shows a generic "USB IO Board."

I'm running v 1.0.5 of the IDE on Win7 64-bit. Things I've tried: - Various USB cables - Hitting the reset button just after clicking upload - Hitting the reset button just after clicking upload, but waiting until the IDE finishes compiling - Uninstalling/reinstalling drivers - Every combination of restarting the IDE and rebooting my computer I can think of

Several forum posts have recommended manually installing drivers. In these posts, they say Windows warns about unsigned drivers. In my experience, I've never made it that far. Windows simply says there are no compatible drivers with the device.

Does anyone have any ideas on what else I can try?

I finally posted my question after all those hours only to discover a solution minutes later! I had tried multiple USB ports on the front of my computer, but decided to try some ports in the back. That's all it took, and now it works fine.