Arduino Micro Not showing in Serial Ports

I bought a new arduino micro board from the local computer store last night and tried to program it. When I plugged it in the bottom LED would light up blue and the top would pulse green for about 13 seconds then start to do a blink type on off sequence. I tried like 5 usb cables and they all it doesn't show up on my mac new or old usb 2 or 3 running the latest version of os X and the lastest arduino software.

I tried some different cables at work and something new happened. The pin 13 green led is on solid and the RX orange led was very very dimly on for a bit then turned off.

Now the pin 13 green led stays solid anytime it is hooked up to power and the blue led stays solid when it is hooked up to power. The other weird thing is that now when I press the rest button the green led gets dimmer but doesn't go out like it used to. Before it would go out and seem to boot the board now it doesn't seem to do anything.

I am running out of idea and things to try. Am I missing something or did I just get a bad board?

I am running out of idea and things to try

Same applies to all readers and potential supporters.

Please read "How to use this forum" and disclose the secrets about:

  • confirm: IDE 1.8.0 ?
  • confirm: Mac OSX version? (latest: =Sierra?)
  • is it an original Micro or a clone?
  • what could you see in the IDE -> is there a serial port coming up (something like: dev/cu.usbserial-...) ?
  • what board did you select under "tools/boards" ?
  • what programmer? (should be set to "ArduinoISP" and NOT to "Arduino as ISP"!)

then start to do a blink type on off sequence

This is the normal "blink" sketch which in most cases is pre-loaded to show that your Arduino is ok and working.

Now the pin 13 green led stays solid anytime it is hooked up to power

That's no good sign. When you hooked up the different cables, did you try to upload something and if so, what sketch?

Am I missing something or did I just get a bad board?

Your board was initially ok (blinking) - now it could be fried by all of your attempts (but there must have been a very bad attempt to connect it to the Mac...).

If you bought it from a local retailer, why don't you go back to them and see if they can check if they sold you a bad board. But first give us the answers to my questions above - maybe we are lucky and it is just something in the setup.

  • confirm: IDE 1.8.0 ? YES 1.8.0
  • confirm: Mac OSX version? (latest: =Sierra?) YES 10.12.2
  • is it an original Micro or a clone? Real Arduino in real Arduino box purchased at micro center
  • what could you see in the IDE -> is there a serial port coming up (something like: dev/cu.usbserial-...) ? Nothing shows up at all with the Micro. With my Uno I get the "dev/cu.usbserial-..."
  • what board did you select under "tools/boards" ? "Arduino/Genuino Micro"
  • what programmer? (should be set to "ArduinoISP" and NOT to "Arduino as ISP"!)

Didn't try to upload anything just plugged them into the board and the cable to my laptop

Never managed to connect, burn send or do anything else with it.

Ok, thanks for the quick update and confirm.
I am also on a Mac, but - never touch a running system - I am still on Yosemite as everything works here as expected. I will only update/upgrade (directly to Sierra potentially, having a backup of my Yosemite at hand) when I don't read any Arduino/Sierra issues anymore here in the forum and elsewhere.

That said - I suspect two potential failure sources:

  1. it could be a bad USB cable (still - in spite of all your testing)
  2. apparently Sierra has problems since it is out to work with original Arduinos which come with an FTDI chip. If you use the forum search there are some people reporting that they managed to get Sierra communicating with the FTDI chip (this is the communication bridge between your Arduino and the IDE).

So, good luck and pls report back when you found a solution so that other Sierra users can benefit from your experience.

Addit and Correction:
Just remembered, but not 100% sure, that the Arduino Micro comes with the same comm chip as the Leonardo (32u) and you need to push the reset button shortly after the compilation is done and the writing process starts; so forget my Sierra/FTDI suspicion as this is only true to Uno's, Nano's etc. which come originally with the FTDI chip.

Not sure I follow with the FTDI chip part are you saying to get an external chip and use it in between? Because my Arduino Uno works perfectly fine the micro is the only one i am having an issue with.

You are right; pls read my addit / correction of the previous post.

Please read this:

These differences affect the way you use the physical reset button to perform an upload if the auto-reset isn't working. Press and hold the reset button on the Leonardo or Micro, then hit the upload button in the Arduino software. Only release the reset button after you see the message "Uploading..." appear in the software's status bar.

-> quoted from here.

The above mentioned sequence applies when - as in your case - the upload process isn't performed via the "auto-reset".

I don't think that will help me since I can't get it to show up on a serial port at all. It is just not seen by the computer

I FINALLY GOT IT TO WORK!

I don’t really know how it happened, but I just danced on the reset, unplug it and plugged it back in. Then did tons of combinations of that at random. Everything from click the rest 30 times and plugin plug out to just plugin plug-out a ton.

The first thing I did once I got to show up was to upload a sketch and now all is great.

Did you click on the link and studied the story about Leonardo and Micro boards in my previous post?
Here it is exactly explained why the board shows up and disappears again on the serial port.

This has to do with the fact that on your board (same applies to the Leonardo) there is NO special communication chip and the Atmel processor does the communication AND the sketch work on the same chip.

Depending on unforeseeable tolerances in the chip/board/cable/PC setup sometimes you can upload sketches without the Reset procedure (see my quote in the previous post), sometimes you need to do the Reset procedure.

So keep that in mind when the next attempt fails again or the board has disappeared again in the IDE.

If you feel that you can master your board now (with or without the reset procedure) then go back to your first post and edit the headline and put a [SOLVED] in front of the headline. This might help people who have the same/similar problem to read what trick made it work.