Arduino micro won't connect to Mac-

Hi everyone,
I recently purchased an Arduino micro for my project and I have spent much longer then I should have to try to get it to show up under serial ports. The Arduino lights up when connected but the mac does not recognize it. It does not even show up in the devices manager. I have also tried to plug into a windows computer and I have had the same issue. The computer is able to recognize other boards such as the mega and uno. This is the second micro I have bought with the same exact issue.
At this point, I have searched through hours of videos and forums trying to get it to work. :frowning:
any help is greatly appreciated.
thanks

confirm: IDE 1.8.0

  • confirm: Mac OSX version (latest: =Sierra)
  • original micro
  • what could you see in the IDE ->nothing
  • what board did you select under "tools/boards" ? arduino micro
  • what programmer? arduino isp

Try using a different USB cable. You may have a charge-only or defective USB cable that provides power but doesn't connect the data lines.

Hi Pert.
Thanks for the advice. I tried using a different cable and even plugged in a different micro usb arduino device with the same cable to confirm it was not the cable.