Arduino mini connection with pc and ESP8266

Hi, I have a problem with my Arduino mini. When I plug the Arduino in, the LED is on but my pc doesn’t always recognizes the Arduino. If it does, it doesn’t display data in the serial monitor. I think it should do that, like it is described in this Video: https://www.youtube.com/watch?v=9QZkCQSHnko . The wiring is also like shown in the Video, but I am using a logic level shifter for tx and rx. The Wifi module also lights up at the beginning, so I should work. The USB port is ok too. My problem is that I can’t connect to the Arduino. I tried uploading a sketch, but the Arduino IDE shows this error:

Arduino: 1.6.12 (Windows 10), Board: "Arduino Mini, ATmega328"

Sketch uses 928 bytes (3%) of program storage space. Maximum is 28,672 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can't set com-state for "\\.\COM3"
An error occurred while uploading the sketch

If I try opening the serial monitor and changing the Baut rate, it shows this:

Error while setting serial port parameters: 115,200 N 8 1

I found out that my Arduino uses a chip made by a company called WCH, and I downloaded the driver for it. I think the installation worked. I’ve also got a problem because I can’t find “Ports” in my device manager. I can only tell if the Arduino is connected or not by the “Port” thing in “tools” in the Arduino IDE. Ps: I am using Windows 10 and I am a noob.

In case you connected the module to RX and TX, you have to disconnect it for uploading a sketch.

Is Pro-Mini a +5 or +3.3v version?

I'm guessing 5 since you mention a (logic) level shifter?

So you have a Pro-mini.. an ESP8266...correct?

Show us pics of the wiring (your set-up)

If you remove the ESP8266 module from the equation, does your Arduino output to the serial monitor correctly?

Thanks for your replies. It's the 5v version of the Arduino. By the way, it's an Arduino clone.

I figured out how to use the ESP8266 with a Arduino mega. My focus is now on getting the other Arduino to work. I don't have any idea what to do. I removed all the wires from the Arduino, but it didn't help. I've got 3 Arduino minis with the same problem.

If you cannot upload any sketches, you may have to flash the boot loader first. How do you program the Minis at all?

I made a stupid mistake. I was using an Arduino nano, not an Arduino (pro) mini. I’ve also tryed selecting the nano, but i did that before installing the WCH drivers. I’m so sorry for wasting your time. :frowning: