Arduino Nano 33 BLE greyed out port button

a couple months ago the nano was working fine, then all of a sudden the port button was greyed out and i couldn't upload any code because i couldn't select the nano's port.

did some research, went through the device manager, downloaded drivers for the nano BLE, added 'legacy hardware' to try and get some new ports, took it to the technical support office for my university, their recommendation was that the nano was fried somehow.

bought a new nano, decided to be more careful with it. it arrived, i plugged it straight into the computer, port button still greyed out.

tried different cables, different computers, reset all my ports using the registry editor. looked through probably 50 forums on the arduino website, reinstalled the IDE multiple times, my computer was restarted multiple times and now im considering factory resetting my computer because the BLE 33 driver is supposed to install itself but for some reason it won't.

i've spent probably 20 hours looking through forums and websites to try and figure this out but nothing has worked so far.

This shouldn't ever be necessary on a new out of the box board, but just because I don't have any other advice to offer, try pressing and releasing the reset button on the Nano 33 BLE board twice quickly. You should now see the "L" LED pulsing to indicate its in bootloader mode (don't worry, it goes out of bootloader mode if you do an upload or power cycle, so this isn't doing anything irrevocable).

After it's in bootloader mode, do you get a port for that board?