Can't select port on Nano 33 ble sense board

I have the same issue, I think. I am on a Mac.

I had an Arduino Nano and it worked fine. Then I got a Nano 33 BLE yesterday and it also gives me the error:

"Couldn't find a Board on the selected port. Check that you have the correct port selected. If it is correct, try pressing the board's reset button after initiating the upload."

When I press the reset button then briefly if I go to Tools menu I will see

"Port (/dev/cu.usbmodem14201 (Arduino Nano BLE 33)"

but after a few seconds it will be gone.

clam61: When I press the reset button then briefly if I go to Tools menu I will see

"Port (/dev/cu.usbmodem14201 (Arduino Nano BLE 33)"

but after a few seconds it will be gone.

What you are seeing is the Nano 33 BLE temporarily going into bootloader mode. With the right timing, you could do an upload during this short window of time. However, the Nano 33 BLE has a nice feature that allows you to make it stay in bootloader mode so you don't need to worry about getting the timing just right:

The tricky thing about the boards with native USB functionality like your board is that the USB code that creates the CDC serial port is running on the same microcontroller as your sketch. This means your sketch code can break the USB code, or stop it from running.

Fortunately, there is an easy way to recover from this situation:

  • Press and release the reset button on your board quickly twice. You should now see the LED on the board pulsing, which means the bootloader is running. The double press causes the bootloader to run indefinitely (until the board is reset, powered off, or an upload is done), which means you don't need to get the timing of the reset just right.
  • Select the port of your board from the Tools > Port menu. The port number may be different when the bootloader is running so don't assume you already have the correct port selected.
  • Start an upload in the Arduino IDE.

The upload should now finish successfully. After this, you should be able to go back to doing normal uploads without needing to press the reset button. If you still need to do the reset trick to do uploads after this, the problem may be caused by your code. You can verify this by uploading a simple sketch like File > Examples > 01.Basics > BareMinimum.

I've deleted your other cross-post @clam61.

Cross-posting is against the rules of the forum. The reason is that duplicate posts can waste the time of the people trying to help. Someone might spend 15 minutes (or more) writing a detailed answer on this topic, without knowing that someone else already did the same in the other topic.

Repeated cross-posting will result in a suspension from the forum.

In the future, please take some time to pick the forum board that best suits the topic of your question and then only post once to that forum board. This is basic forum etiquette, as explained in the sticky "How to use this forum - please read." post you will find at the top of every forum board. It contains a lot of other useful information. Please read it.

Thanks in advance for your cooperation.

So I put the device into bootloader mode, selected the port, and ran BareMinimum.

The error is now "No device found on cu.usbmodem1401"

is it possible that my device is defective?

After you put the Nano 33 BLE in bootloader mode, do you see its port listed in the Tools > Port menu?

Recently I purchased a NANO 33 BLE SENSE Board with Headers. ~While connecting it to my PC (Windows 10), its not being listed in Device Manager - Other Devices Section or Ports (COM & LPT) section. ~Same time, Arduino shows me Rainbow light at the start and then Green Stable/Constant light, and Yellow/Orange Blinking light (about 1.5 seconds delay). Rainbow light just shows one time and goes away after that. ~Also tried pressing Reset button twice which indeed turned Yellow/Orange Light to very slow blink. But still I am not able to see Port Number. ~I tried installing Board Manager > nRF528x both versions 1.1.0 and also 1.1.6 ~I do not see a problem is due to cable as I have changed 2-3 cables.

PLEASE HELP ME. THX.