Arduino Nano A000005 - requires older version of ide to upload code

Has anyone any experience of this? After exhausting all other trouble shooting options, I’ve been advised that this Nano requires an older ide to be able to upload code, I believe versions 2 & 3 have already been tried unsuccessfully. Does anyone know which version it would be. After that it’s the boot loader however I’m not confident to begin to do this.

If you've updated the AVR board package to latest one, you just need to select the (Old Bootloader) version from the processor submenu in tools menu.

I'm running 1.8.5. I'm not given an "old bootloader" option. I reinstalled the IDE just to be sure.

If there's no old bootloader version, you're using a version that only supports the old bootloader version, and no special action is needed (and any problem you might have is unrelated).

This only applies if you have updated the AVR board package using board manager to the latest one which supports the new bootloader.

jonrbryan:
I'm running 1.8.5. I'm not given an "old bootloader" option. I reinstalled the IDE just to be sure.

It's not the IDE you need to update .

Start the IDE.
Tools ---> Board ---> Boards Manager
select Arduino AVR Boards
there should be a button labeled Update

.