Arduino Nano Atmega328p

I bought an Arduino nano (obviously a clone) off eBay last year and i still cannot seem to be able to upload anything to it. I select the board as Arduino Nano and the processor as ATmega 328 but the correct port never seems to appear and obviously when i try to upload it has the error message as if you have forgot to plug it in. It does have power to the board as it is performing the default blink program. I have also tried different cables but it has made no difference. I wonder if it has something to do with the fact that the processor is the ATmega 328p rather than just 328 or maybe it doesn't matter. I have tried a fair few different things but no difference. If someone has any ideas or suggestions (it could be something awfully obvious), or have been in a similar situation please reply as I would love to start using this fantastic little board. Thanks, Darcey

Is it correctly recognized in the device manager? Do you have the drivers installed; clones often have a CH340 chip (or something like that; not quite sure of the name); do a search here.

If it's a nano from last year on ebay and has the ftdi chip inste of ch340g it may be a counterfeit ftdi chip - Google ftdigate for more info.

If it has 340g, just download and install the drivers.