Arduino Nano Every upload / driver / COM Port problem Win10

Hi

As mentioned in title.
In Windows 10 Pro, 20H2, 19042.1110.
Arduino Nano Every
Arduino IDE 1.8.15.

Arduino COM port isnt recognized / installed and I am unable to upload.
Device Manager ports only show COM1.
I have installed the megaAVR boards 1.8.7 in board Manager.
I have tried to manually install the driver from github, from DEvice Manager -> Add Device from disk. However the drivers show an error (exclamation mark triangle icon) that "device cannot be started".
I have uninstalled and reinstalled megaAVR boards to try and trigger reinstallation of the driver but also no success.

Nothing seems to work.

Which Arduino IDE file did you download from where and how did you install it.

Ok, thanks for the support but in the end I saw a post on reddit that triggered me to check my USB cables and apparently the cable I was using somehow was made only to send power ?! ... anyway, a different cable solved my problem...

1 Like

That was a quick and easy fix ! I'm glad it is working now :smiley:
Don't hesitate to ask when you run into trouble. I mainly answer questions about millis() and I2C.

1 Like