Arduino Nano Serial Port error on Mac OSX Catalina 1.15.4

Hello!

I have just recently bought my first Arduino board. Unfortunately when I went to upload my first sketch i got an error message saying that no serial port could be detected.
Under Tools>Ports I can only see something with the name of my bluetooth headphones and “Bluetooth-Incoming-Port”.

I did some digging and made sure to (even though I definetly have a genuine board) install all of the recommended drivers (FTDI VCP USB Serial Driver, CH341SER), I tried the newest versions (including betas) of both the normal Arduino IDE and the Pro IDE, switched cables and USB-C dongles.
As far as I can tell the Arduino doesn’t even show up as a USB device (see attached screenshot), however the LEDs show that it has power.

I then tried connecting the board to an older mac running OSX 10.10.x and everything worked perfectly.

At this point I just don’t really know what to do anymore besides waiting for a new update (?) This has already caused me quiete a few hours of serious headache and frustration…

If you need any further information (screenshots, technical details, whatever) please feel free to ask.
The Board I am using is an Arduino Nano with an ATMEGA328P and an FTDI232RL.

Greetings,
Max