Arduino NG with ATMEGA168 bootloader problems

maybe someone of you encountered such problems: i'v tried to burn a bootloader (using a parallel programer) to the 168 but without any sucsess. in the arduino enviorment it says:

avrdude: AVR device not responding avrdude: initialization failed, rc=-1 Double check connections and try again, or use -F to override this check.

the thing is that i'v burned a bootloader to a ATMEGA8 sucsessfully (not trough the arduino enviorment, it gave the same massege. i used ISP PROGRAMMER by Adam Dybowski) and it worked.

trough isp programmer i also tried burn a small led controlling program to thest the chip, it was burned and worked but the timing of the program (delays) were trippled :-?

i have tried to burn an older bootloader also but with same results: when i try to d/l a sketch it gives the following massage:

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

has any idea about what's going on ??

Was the first error you mentioned what you got when you tried to burn the bootloader? Or once you had burned the bootloader and tried to upload a sketch?

From the LED timing, it sounds like the fuses on the chip are wrong. The Burn Bootloader commands not only burn a hex file but also set the fuses. If you burn the bootloader outside the Arduino environment you need to set the fuses as well.

i couldn't burn it from the arduino environment ... only trough other apps and the bootloader didn't burn eventualy ... only a sketch without the bootloader