Arduino not recognized as device by Windows 7

Hi!

I've had my Arduino Uno for a month now and have been able to upload sketches until suddenly it is no longer being recognized as a device. When I plug in the USB, absolutely nothing is listed in the device manager, not even an "unknown device" label.

I'm afraid that my chip has been fried but I'm not sure. The green ON led still turns on and the L led still turns on as well when the Arduino is plugged in. The computer just won't recognize it as a device at all. I have also tried on different computers and none work. Is there a way to tell if my Arduino is simply broken or could something else the issue?

(I have reinstalled the drivers also and am pretty sure the software isn't the issue since the device isn't showing up at all in the first place)

Thank You!

Hm hm hm.

Try to program atmega328p with ISP and external programmer (first check there are 5 volt and the regulator is working). If atmega328p responds well, then try to rewrite atmega16u2. If it responds well, you revived your arduino congratz. If not then you burnt the chip.

Will it run the sketch you had programmed in it?

Just discovered that the problem was a bad USB cable. After getting a new one all the sketches run fine as usual. Thanks for the tips though!

I've got the same issue here. Everything was working fine and then it stopped. I was making connections with the board powered on (stupid, I know) and it's possible that something might have shorted out.

I too have an Uno and am running Windows 7. When I plug in the board via USB, it powers up and will run the last program uploaded to it. Both the 3VDC and 5VDC on the board are producing accurately. I've tried three different USB cords and three different computers.

Any ideas would be appreciated.