Arduino not turning on when when plugged in

As above, Arduino does not turn on when plugged into the computer. Have currently attached a servo and potentiometer to it for controlling RC car steering
help quickly

Which Arduino board are you using ?

Disconnect everything from it and plug it in, presumably using a USB port. Does the PC recognise that the Arduino has been plugged in and create a COM port ?

Have you tried a different USB lead and port on the PC ?

The more information you provide the more likely it is that you will get help

Arduino Uno copy . It suddenly started recognizing I mean that the power is coming now. earlier happened I plugged in my wire and the on led became
on for 1 sec and dimmed and went away

but still i am not able to run servo on it ot read potentiometer values. circuitry was right according to tutorial

Well your tutorial or your wiring is wrong.

You should not power a servo motor from the Arduino, as it is NOT a power supply.

servo means sg90

servo moves once every 5 min
and sometimes it starts working like now and then stops

sorry for bothering,found problem,signal wire broken from inside

1 Like

@Abeer_goel, great that you found the problem. You can indicate that the topic was solved by clicking the solution checkbox under the most useful reply (your post #8 in this case); that way others know that it was solved.

@sterretje i found it but it has happened to me for third time