Arduino on Mavericks 10.9.4 not opening... a Java error?

Hey all.

So, I just bought a new Macbook Pro with 10.9.4 installed, and when I installed the Arduino IDE, everything went smoothly. Every time I open it, though, I’m presented with the following error:
!(http://forum.arduino.cc/Users/stevepratt/Desktop/Screen Shot 2014-08-10 at 6.31.19 PM.png)

Apparently, Apple doesn’t provide any Java with their new computers…weird…so I need to install it…

I installed the Java SE 8u11 JDK to update to the newest version. But, Arduino wants Java SE 6, not Java 8.

I did some research to find this discussion (Mac OS X 10.9 Java 1.7 only · Issue #1665 · arduino/Arduino · GitHub) of getting the Arduino to use the right Java library, but I get lost quick in the techno-babble…

Can someone point me in the right direction? I got Arduino to work just fine on my other Mac running Mavericks, so I’m confused on where to go from here just to get the program going.

Regards,
Steve

Here is the screenshot of the error, BTW.