Arduino Pro Mini and Bluesmirf Gold not talking

Hi guys, I hope this has not been answered before, I did search around for a while. I am new to Arduino and the forum.

Here is my problem. I have an Arduino Diecimila, and a Bluesmirf gold. I have a simple program on the arduino that blinks a led. When I send a '1' from my computer through the BT, the led stays on. When I send a '2' it turns off. It is a simple test program and works fine. The issues started when I tried to replace the Diecimila with an Arduino Pro Mini (3.3v 328). I can upload the program to the mini and the led blinks, but the commands sent through BT don't change the led state. Why would this work on the Diecimila, but not the mini? I know the program is running on the mini, and I know the BT is working. Also, I have tried running both the BT and Arduino at 115200, 38,400, and 9600. Each baud rate works on the Diecimila and not on the Pro Mini. Could it be a 3.3 to 5 volt thing? I'm powering the whole project off the sparkfun usb to serial 3.3 volt programmer.

Thanks for your help! Tom

Ok,here is more to the mystery, but perhaps the problem has been isolated. Previously I was trying to get the arduino pro mini to turn an led on and off. Now, I've programmed it to receive a serial command and send it right back. I opened up the serial monitor (at the moment I'm running at 19200 on the monitor and arduino) and when I send a '1', I get a 'n?' back. There is a ~ over the n. I get 'o?' if I send a 2. What am I doing wrong here?

Thanks!

BTW, any idea what the baud rate of the boot loader and programmer are? I'm a newbie and could only find the info for the 168 chip bootloader and I'm running a 328. Maybe they are the same.

Man, I'm just talking to myself here. At least some others have viewed this post. Anyway, I found this link:

http://itp.nyu.edu/physcomp/Labs/SerialDuplex

Which explains the wierd characters I've been getting in the serial communications window. I was just using the wrong serial print command. Unfortunately, I'm now at work and Arduino-less until later.

Still, anyone else have serial communication issues like this? It seems like both devices work fine by themselves.