arduino pro mini not uploading any more

Hey guys,

I recently had my first try on the arduino pro mini, 5v 16Mhz with a 328p chip.

I also bought one of these ftdi adapters with the DTR pin to program it.

So I started to test the board by uploading a sample blink program. It instantly got uploaded and it worked. I test it few more times by burning few other programs. Sometimes it did not, so I reconnected it and it started working.

Now after I tried to solder two female jumpers for the i2c pins a4 and a5, i burnt the blink program again. It got uploaded. But after this, it is not accepting any programs. The IDE keeps saying uploading for a long time and throws 10 attempts of errors, each time with different error codes.

Although, when i power the board, it initially blinks thrice for 5 times( I guess its the bootloader), and starts blinking with a 500 ms delay as i had programmed.

I am only powering it with vcc pin through the ftdi plugged to my laptop's usb port.

I am not sure where or what the problem is. Can someone please try to help me figure it out? TIA :slight_smile:

It sounds like a Chinese mini.

Double check your soldering very carefully on all the pins.
I bought a batch of 5 and one did not want to play nice.
Simply did a quick reflow of all the solder joints with a fine tip and BINGO it was alive again.

Well, i ll try checking the soldering on all the pins again.. by the way. do u think the pro mini is bricked?

As of now, when i power it, the led flashes in short bursts for a few seconds and then the led starts blinking as per the blink program i had uploaded earlier..

So, do you think anything else might be a problem apart from the wiring or soldering..?


It is simply impossible to tell if it is "bricked" from here without a lot more information.

Best bet is remove ANYTHING connected to it double check solder joints and upload the blink but modify it to a different flash rate to see if it does go up and if it does then you can easily tell by the flash rate.