Arduino Uno and Arch linux

Hello all, I am hopeful I can get some help to resolve a problem I'm having.

I just got my new Arduino Uno, tried uploading the default blink program to the board, and get this error:

"avrdude: Yikes! Invalid device signature. Double check connections and try again, or use -F to override this check."

I did a little googling and found out it's because of an incompatability between avr versions on the board vs on my computer(I think). Does anyone have some advice that I can try. Or, where to I use the -F switch?

Any help is appreciated, thank you.

What version of AVRDUDE do you have? I'd suggest upgrading to the latest version (5.10 I believe).

-- The Quick Shield: breakout all 28 pins to quick-connect terminals

Thanks RuggedCircuits. I already solved the problem by exploring around some more google searches. I can't find the link to what the solution was now, so I'll just repeat what I did here.

I had previously installed arduino via PKGBUILD(from http://aur.archlinux.org/packages/arduino/arduino/) / makepkg -i. Solution was a small edit to the PKGBUILD.

Note that these steps were done AFTER I had installed what wasn't working. If you haven't previously installed, skip step 1, download the necessary files(PKGBUILD, etc.), cd to the dir, and issue the following.

  1. pacman -Rsn arduino
  2. nano PKGBUILD
  3. Comment out both of these lines:

"# rm ${pkgdir}/usr/share/arduino/hardware/tools/avrdude" "# ln -s /usr/bin/avrdude ${pkgdir}/usr/share/arduino/hardware/tools/avrdude"

and add: "chmod 755 ${pkgdir}/usr/share/arduino/hardware/tools/avrdude"

So those lines should now look like this:

" # rm ${pkgdir}/usr/share/arduino/hardware/tools/avrdude

ln -s /usr/bin/avrdude ${pkgdir}/usr/share/arduino/hardware/tools/avrdude

chmod 755 ${pkgdir}/usr/share/arduino/hardware/tools/avrdude"

  1. makepkg -i
  2. pacman -U arduino-0021-2-i686.pkg.tar.xz

and that was that :).