Arduino uno on Windows 7 32 bit, that device cannot start ( code 10)

Hi,

Tried to install Arduino uno on Windows 7 32 bit, get the error “This device cannot start (Code 10)” , are there any jumper settings on the board to be done ?

The log in C:\Windows\inf\setupapi.dev.log is attached:

setupapi.app.log (292 KB)

ravi_pathak123:
Hi,

Tried to install Arduino uno on Windows 7 32 bit, get the error "This device cannot start (Code 10)" , are there any jumper settings on the board to be done ?

The log in C:\Windows\inf\setupapi.dev.log is attached:

Board Works in another PC?

tried on my laptop, doesn't work

Can you attach the setupapi.dev.log?

You attached the app log

ravi_pathak123:
tried on my laptop, doesn't work

If driver is installed by you = means board may have some problem. Otherwise I recommend you to use Arduino Forum and in the setup process it will install the drivers, then try again.

PFA the setupapi.dev.log file

setupapi.dev.log (80.1 KB)

How are you installing the driver?

The log indicates you are doing a "force" install and you are pointing it to the Arduino USBSerial.inf file.

First, you should not need to do a force install.
Second, you are forcing it to use the wrong file.

The following procedure will help you install the drivers for your Arduino board on Windows:

Go to Device Manager
Right click the Arduino device in Device Manager
Select Update Driver Software
Select Browse my computer for software
Click Browse button
Select the Drivers folder under the location of your Arduino software installation. (Do not select the FTDI folder inside the Drivers folder)
Click OK
Click Next

I did exactly the same thing for more that 10-15 times but without any results, last time i attached the log with some data deleted because it was too big, PFA the full zipped log

setupapi.dev.rar (221 KB)

Here is the relevant section from the log on my system.

Notice the first line from my log snippet:
[Device Install (DiShowUpdateDevice) - USB\VID_2341&PID_0001\64932343738351410122]

This is the device that it is installing the drivers for. It is a USB device with the Arduino UNO VID/PID

In your logs it shows your are trying to install the drivers for:
[Device Install (DiInstallDevice) - ROOT\PORTS\0000]

This does not seem correct.

What device shows up in Device Manager when you have the Arduino connected to the system? Can you attach a screen shot of the Device Manager with it connected?

[Device Install (DiShowUpdateDevice) - USB\VID_2341&PID_0001\64932343738351410122]
>>>  Section start 2012/09/08 11:07:08.253
      cmd: "C:\Windows\system32\mmc.exe" "C:\Windows\system32\compmgmt.msc" /s
     dvi: {DIF_UPDATEDRIVER_UI} 11:07:08.268
     dvi:      No class installer for 'Arduino Uno'
     dvi:      Default installer: Enter 11:07:08.268
     dvi:      Default installer: Exit
     
     ...

     ndv: {Update Driver Software Wizard exit(00000000)}
<<<  Section end 2012/09/08 11:08:03.137
<<<  [Exit status: SUCCESS]

I can give access of my machine to u thru teamviewer.....is it fine?

I had the same problem, searched all the forums and then thought, "Maybe I have a bad USB cable?" (It's a brand new cable that I bought with the board). Turned out that swapping it with another cable I had on hand solved the problem.

Reinstalled the drivers and this time I didn't even need to force the install to "Add legacy hardware."

Thanks wizmotr, trying another USB cable did the trick for me as well :slight_smile:

i change so many cables and my problem is not solved... plz help!

Changing cable worked for me as well! 8)

Thanks,
Cabbi

I have same problem, but 3 cables (older) are all behaving the same way. One has to force insta;; the inf. Seems Windows does not detect the Arduino properly.

I have brand new Genuine (italy) Arduino Uno rev3) and Windows 8.1 - Driver installs, but Code 10 afterwards.

I think I have found solution to the problem described above in case of arduino uno with CH340 USB-to-serial chip in Winodws 7 32 bit. Just update the COM driver with drivers for CH340 USB-to-serial chip which can be downloaded from DCcduino usb drivers (CH340 / CH341 chipset). Although the site describes a solution for Macbook, it contains also drivers for windows. This solution worked for me. (Exchange of usb CABLE and Arduino driver reinstalation did not work for me).
with regards
Bartek

this is how i solved my problem

Plug in your board and wait for Windows to begin it's driver installation process. After a few moments, the process will fail, despite its best efforts
Click on the Start Menu, and open up the Control Panel.
While in the Control Panel, navigate to System and Security. Next, click on System. Once the System window is up, open the Device Manager.
Look under Ports (COM & LPT). You should see an open port named "Arduino UNO (COMxx)". If there is no COM & LPT section, look under "Other Devices" for "Unknown Device".
Right click on the "Arduino UNO (COmxx)" port and choose the "Update Driver Software" option.
Next, choose the "Browse my computer for Driver software" option.
next select "let me pick from a list of device ".
select "Arduino LLC" from "manufacturer" and pick "arduino uno r3" from "model"
Windows will finish up the driver installation from there.

my laptop was not finding the driver when drivers folder was selected so i followed this method
:slight_smile:

sorry to dig up an old thread, but was there ever a solution to this? I am having a similar problem and can't figure it out.

bmasojc:
DCcduino usb drivers (CH340 / CH341 chipset)

As stated you must install the CH340 serial chip driver if you have a cheap Chinese knock off arduino that looks like this:


The chip in question is located under the crystal next to the usb port.

For me the only thing that worked was downloading the drivers from the Chinese website: CH341SER.ZIP - 南京沁恒微电子股份有限公司

And install as adminstorator! The files provided from the google drive did not work for me.

I have an original Arduino Uno (made in Italy… supposedly) and I had the same problem.

It seems to me that something on the board was corrupted after I did some stuff to it. I fixed it by using zadig software.
http://zadig.akeo.ie/

selected the options> list all devices > select Arduino Uno from list> select WinUSB(v6.1.7600.16385) from the list and “replace driver”

I then went to device manager and installed the driver from the list of available drivers on my computer as previously suggested on the thread.

The board works fine now. I hope this helps if all else failed.